Support forums
in

Issue with pasting content in Chrome

Last post 03-01-2012, 2:21 PM by alekop. 11 replies.
Sort Posts: Previous Next
  •  02-16-2011, 6:15 PM 66265

    Issue with pasting content in Chrome

    Hello,
    I am getting an error  "Error, INVALID_NODE_TYPE_ERROR: DOM Range Exception 2" when trying to paste content into the editor.
    I am using 
    Cute Editor for .NET version 6.3.
     
    Could you please help.
    Thanks in advance.
     
    Filed under: ,
  •  02-16-2011, 7:02 PM 66267 in reply to 66265

    Re: Issue with pasting content in Chrome

    Dear MO1,
     
    Please upgrade to latest version and test it again. The upgrade is free.
     
    How to upgrade to latest version?
    Please follow steps:
    1. Backup your website
    2. Remove folder "CuteSoft_Client"
    3. Download cuteeditor for .net, download link: http://cutesoft.net/downloads/folders/cute_editor_current_releases/entry21904.aspx
    4. Unzip it
    5. Upload files of folder "\Framework 2.0\bin" to your application bin folder, it will override your previous files with same name.
    6. Upload folder "CuteSoft_Client" and all file it contains to http://{your site}/{your application}/ on your web site
    7. Migrate your customization of old version to latest version
    8. Copy the permanent license to "bin", you can find the permanent license from your backup, license file name is "cuteeditor.lic"
    9. Test it
    Thank you for asking
    Eric@cutesoft.net  
  •  02-16-2011, 8:46 PM 66269 in reply to 66267

    Re: Issue with pasting content in Chrome

    Thanks a lot!
  •  11-14-2011, 7:33 AM 71370 in reply to 66265

    Re: Issue with pasting content in Chrome

    MO1:
    Hello,
    I am getting an error  "Error, INVALID_NODE_TYPE_ERROR: DOM Range Exception 2" when trying to paste content into the editor.
    I am using 
    Cute Editor for .NET version 6.3.
     
    Could you please help.
    Thanks in advance.
     
     
    Hello
     
    The same is happing for us using version 6.6 and Chrome (Safari works fine though).
    The editor field appends a "pasting" and alerts the above error. 
    Strangely enough it's not happening on your example page, the pasting works fine there.
     
    Thanks for your help.
    Regards,
    Stefan Senn
    Filed under: , ,
  •  11-14-2011, 8:43 AM 71373 in reply to 71370

    Re: Issue with pasting content in Chrome

    Hi Comartis,
     
    We have fixed this issue in the latest version, please download the package below and try again.
     
    http://www.cutesoft.net/downloads/folders/21904/download.aspx 
     
    Regards,
     
    Ken
  •  11-15-2011, 5:01 AM 71383 in reply to 71373

    Re: Issue with pasting content in Chrome

    Hello Ken
     
    Thank you for answering this quick.
    I will try again with your download asap.
     
    Regards,
    Stefan Senn 
  •  11-15-2011, 8:17 AM 71388 in reply to 71373

    Re: Issue with pasting content in Chrome

    Hello again
     
    I checked with the new version and the pasting in Chrome works.
    Unfortunately now the FocusDocument() API call seems not to work anymore in Chrome and Safari.
    Are there any known causes of this behaviour?
     
    Thanks for your help.
     
    Regards,
    Stefan Senn 
  •  11-16-2011, 6:45 AM 71411 in reply to 71388

    Re: Issue with pasting content in Chrome

    Hi Comartis,
     
    Please try the example page below, it works fine for me.
     
    Focus on the text box, then click the button.
     
    <%@ Page Language="C#" AutoEventWireup="true" %>

    <%@ Register TagPrefix="CE" Namespace="CuteEditor" Assembly="CuteEditor" %>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head id="Head1" runat="server">
        <title></title>
    </head>
    <body>
        <form id="form1" runat="server">
            <asp:TextBox ID="tb1" runat="server"></asp:TextBox>
            <CE:Editor ID="Editor1" runat="server">
            </CE:Editor>
            <input type="button" value="Focus Editor" onclick="focusEditor()" />
        </form>
    </body>
    </html>

    <script>
    function focusEditor()
    {
        var editor1=document.getElementById("<%= Editor1.ClientID %>");
        editor1.FocusDocument();
    }
    </script>
     
    Regards,
     
    Ken
  •  11-29-2011, 6:46 AM 71701 in reply to 71411

    Re: Issue with pasting content in Chrome

    Hello
     
    Sorry that it took so long for replying to your answer.
    It seems that it is somehow related to how we use the FocusDocument on our site.
    Strangely enough it worked fine before upgrading CuteEditor.
    But I created a testbutton with a call to FocusDocument and that worked fine... so it has to do with normal usage of FocusDocument.
    Thank you for your help!
     
    Regards,
    Stefan Senn 
  •  02-23-2012, 12:13 PM 73134 in reply to 66267

    Re: Issue with pasting content in Chrome

    I am still getting this error with 6.6.
     
    First Ctrl+V: 
          Message Uncaught Error: INVALID_NODE_TYPE_ERR: DOM Range Exception 2 in Chrome console
     
    Second Ctrl+V:
          An alert comes up with this message: Error,INDEX_SIZE_ERR: DOM Exception 1
  •  02-24-2012, 6:32 AM 73160 in reply to 73134

    Re: Issue with pasting content in Chrome

    Hi alekop,
     
    I works fine for me. Can you reproduce this issue on demo http://www.cutesoft.net/example/general.aspx ?
     
    If the demo works for you, please download the latest version and try again.
     
    Latest version downloads http://www.cutesoft.net/downloads/folders/21904/download.aspx
     
    Regards,
     
    Ken 
  •  03-01-2012, 2:21 PM 73276 in reply to 73160

    Re: Issue with pasting content in Chrome

    It turned out to be an incomplete upgrade job on our part. :) Thanks.
View as RSS news feed in XML
Powered by Community Server (Commercial Edition), by Telligent Systems