Support forums
in

focus form problem

Last post 02-03-2011, 8:34 AM by Eric. 1 replies.
Sort Posts: Previous Next
  •  02-03-2011, 5:42 AM 66034

    focus form problem

    Hi all,
    I have integrate phpfileuploader into a form page. It's all ok and phpfileuploader work weel.
     
    The problem is that phpfileuploader is in conflict con other form fields like text input.
    When you click on a text field you can not write in it. I have to change focus and come buck on text field to write in. If I click on the text field I cannot wite again.
     
    Please help me.
     
  •  02-03-2011, 8:34 AM 66036 in reply to 66034

    Re: focus form problem

    Dear christianm,
     
    I tested the issue in the following snippet, it works fine and cannot reproduce your issue:
    <?php require_once "phpuploader/include_phpuploader.php" ?>
    <?php session_start(); ?>
    <html>
    <head>
    <title>Example</title>
    </head>
    <body>
    <form name="theForm" action="1.php?postback=true" method="post">
    <h1>Example</h1>
    <table>
     <tr>
      <td>Subject:</td>
      <td><input name="subject" type="text" id="subject"
       style="width: 170px;" /></td>
     </tr>
     <tr>
      <td>From:</td>
      <td><input name="from" type="text" id="from" style="width: 170px;" />
      </td>
     </tr>
     <tr>
      <td>To:</td>
      <td><input name="to" type="text" id="to" style="width: 170px;" /></td>
     </tr>
    </table>
    <br />
    <br />
    <br />
    <?php
    $uploader=new PhpUploader();
    $uploader->MultipleFilesUpload=true;
    $uploader->InsertText="Select multiple files (Max 1000M)";
    $uploader->MaxSizeKB=1024000;
    $uploader->Render();
    echo '<br \>';
    echo '<br \>';
    if(@$_POST["subject"]!=null)
    {
     echo $_POST["subject"];
     echo '<br \>';
    }
    if(@$_POST["from"]!=null)
    {
     echo $_POST["from"];
     echo '<br \>';
    }
    if(@$_POST["to"]!=null)
    {
     echo $_POST["to"];
     echo '<br \>';
    }
    ?></form>
    </body>
    </html>
    How can I reproduce this issue? Can you share your code and tell me the detailed reproduce steps?
     
    Thank you for asking
View as RSS news feed in XML
Powered by Community Server (Commercial Edition), by Telligent Systems