Support forums
in

IE6 incredibly slow

Last post 08-30-2007, 7:21 AM by AndyFel. 24 replies.
Page 1 of 2 (25 items)   1 2 Next >
Sort Posts: Previous Next
  •  08-10-2007, 5:36 AM 32369

    IE6 incredibly slow

    Hi
     
    We recently upgraded the editor to V6 on our live site. Since then all users using IE6 have been complaining of major performance issues. It can sometimes take up to 5 mins before the editor has downloaded all the relevant files for the editor. It only seems to affect IE6, 5.5 and 7 and firefox clones all work fine! (well except for loads of activeX warnings under IE5.5 but we have always had those!)
     
    When loading the editor you can see in the status bar it starts with about 60 files to download, it goes OK, then seems to stall on random ones. However what is very strange is that the filename its downloading never seems to change. It always says load.ashx?type=image&file=blank2020.png.
     
    On testing your demo page the editor itself shows in about 10 secs, then it takes another 30 secs or so to download another 100 files all of which seem to have the same URL as above. Using IE7 etc its fine the page shows in a couple of seconds. I have never had it stall on your site. Question is why does IE6 insist on downloading all these files, we did not have a problem with V5.3.
     
    Any ideas on IE6?
     
    Thanks
     
  •  08-10-2007, 8:13 AM 32371 in reply to 32369

    Re: IE6 incredibly slow

    AndyFel,
     
    Can you reproduce the problems in the following example?
     
     
    If you check the HTML code of the page, you can find the following code:

     <!-- CuteEditor ctl01 Begin -->
     
    .............
     <!-- CuteEditor ctl01 End c1 ms140.625-->
     
    ms140.625 is the loading time of Cute Editor.
     
    If not, you may have some configuration problems.
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  08-10-2007, 10:57 AM 32377 in reply to 32371

    Re: IE6 incredibly slow

    Hi
     
    On your demo page the average figures were about the same as above, but I am not convinced these really mean anything in this situation because I can view the source and get these figures long before the 100+ files have finished downloading. I am guessing these are server side figures, of which i dont have a problem with on your demo or our code.
     
    The problem is that we are waiting ages for these 100+ files to download before we can use the editor. On IE7 etc it downloads about 2 files and off we go (has the same average figures in the HTML).
     
    Its almost as if IE6 is not caching any of those files at all!
    For my 2 cents worth I think the problem is because you are now downloading all images and files via this load.ashx file which IE6 is not caching because it thinks its dynamic. Whereas before (V5.3) all images etc were referenced directly and downloaded once and cached.
     
    However not sure how this helps.
    Hope you have some ideas.
  •  08-10-2007, 11:05 AM 32380 in reply to 32377

    Re: IE6 incredibly slow

    AndyFel,
     
    Can you reproduce the problems in the following example?
     
     
    If you check the HTML code of the page, you can find the following code:

     <!-- CuteEditor ctl01 Begin -->
     
    .............
     <!-- CuteEditor ctl01 End c1 ms140.625-->
     
    ms140.625 is the loading time of Cute Editor. This is pretty fast.
     
    Please let me know this number when you test it.
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  08-10-2007, 11:13 AM 32381 in reply to 32377

    Re: IE6 incredibly slow

    >>The problem is that we are waiting ages for these 100+ files to download before we can use the editor.
     
    It looks like the images are not cached by the browser.
     
    Go to IE tools, choose Internet Options, click on "Settings" under Temporary Internet Files and make sure you you didn't select the "Every visit to the page" radio button.

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  08-12-2007, 7:53 PM 32403 in reply to 32377

    Re: IE6 incredibly slow

    FYI,
     
    We just deployed CE on one of our test public websites. Here's the timing:
     
    Running an older WinXP/IE7: Takes about 10 secs first time to load the page, menus and all the baggage. When I open a file from a pop-up document manager, the file opens and the page (including CE) redisplays in less than 2 secs...
     
    Running on a very old 500 mhz notebook - Win2k Pro/IE6 initial page load: 14 secs. Load a file and redisplay: 3 1/2 seconds...
     
    Must be something in your settings...
     
    Our web page has over 100 image files, BTW...
  •  08-13-2007, 7:08 AM 32406 in reply to 32403

    Re: IE6 incredibly slow

    Hi
     
    Have checked the internet settings and its set to automatic, have tried never and it didnt make any difference. We have also done a fresh install of IE6 into a virtual PC, so we are just using default settings.
     
    BTW those figures are ms140.625, but as I can view these long before the images are downloaded I thought they were irrelevant.
     
    I think we all agree its because IE6 is not caching all those images. Question is why!!!!
     
    We are beginning to think its something to do with IE6 interaction with the firewall as it only seems to affect all users on a certain network. What is strange tho is that if we use V5.3 its fine, but with V6 its very slow using IE6.
     
    Hohum.... Any further suggestions or ideas are welcome..... (short of downgrading back to V5.3)
     
    Thanks
  •  08-13-2007, 5:44 PM 32426 in reply to 32406

    Re: IE6 incredibly slow

    We've now deplyed on 8 sites, some internal fully firewalled; others public. They are all as fast or faster than the times I posted.
     
    I doubt very much that it's V6 CE that's causing your issues. Try deploying to another network.
  •  08-14-2007, 12:28 AM 32434 in reply to 32426

    Re: IE6 incredibly slow

    Hi Adam,
     
                        It is taking more than 10 seconds for us to load the cuteEditor with normal configuration.we just need only the 15 functionalities of cuteEditor so we tried to remove the rest from the configuration file but still, loading the cuteEditor in IE6.0, it is showing downloading some 100 images like that.We are using CuteEditor 6.0, Can you please give a solution to improve the loading time of CuteEditor and how to modify the config files to improve perfomance
  •  08-14-2007, 2:05 AM 32435 in reply to 32434

    Re: IE6 incredibly slow

    covalense:
    Hi Adam,
     
                        It is taking more than 10 seconds for us to load the cuteEditor with normal configuration.we just need only the 15 functionalities of cuteEditor so we tried to remove the rest from the configuration file but still, loading the cuteEditor in IE6.0, it is showing downloading some 100 images like that.We are using CuteEditor 6.0, Can you please give a solution to improve the loading time of CuteEditor and how to modify the config files to improve perfomance
     
    covalense,
     
    The load speeding of Cute Editor V6.0 should be very fast. It looks like you may have configuration issues.

    Please try the following links:

    http://cutesoft.net/example/general.aspx   (Cute Editor for .net)

    http://cutesoft.net/asp/EnableAll.asp   (Cute Editor for ASP)

    http://phphtmledit.com/EnableAll.php  (Cute Editor for PHP)

    If you don’t have problems with the above links, please try Cute Editor for .net download package:

    http://cutesoft.net/downloads/default.aspx

    And make sure you can run the examples successfully.
    If you have no problems with examples in the download package, but have problems with the production site. Please upload the examples to your server and test again.
     
    Keep me posted
     

     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  08-14-2007, 9:49 AM 32448 in reply to 32435

    Re: IE6 incredibly slow

    We work for the MOD and we cannot change networks, we have what we are told. So changing network settings etc is impossible. Its virtually impossible to find out what is set!
     
    Just rolled back our testsite to V5.3 and the speed difference is incredible. V5.3 zooms so fast its like a dream!
    But our main problem is that V5.3 is no longer supported and V6 has a load of fixes in that makes rolling back very undesirable.
     
    I shall be setting up a Virtual PC at home and will test IE6 from there, just dont like wasting time at home working ;-)
     
     
     
     
     
     
     
  •  08-15-2007, 9:20 AM 32492 in reply to 32448

    Re: IE6 incredibly slow

    Right played with this at home, it was faster, but in IE6 it still takes quite a while to download all the 100 plus files on first load or refresh, at least it didnt insist on downloading them everytime the page was submitted, unlike the MOD network which insists on downloading all 100 plus files everytime in IE6. On all other browsers it seems to get these from cache everytime.
     
    I think this is impacted more because the MOD network is heavily used and with IE6 insisting on downloading all these files it takes even ages. Have you tried using IE6 over a dialup link? It used to be fine but now.....
     
    I am more than sure its the way all the files are loading via the load.ashx file, as the old V5.3 images were fine and were cached everytime. You may have sped up the server side, but you have crippled the editor on this network.
     
    So now I have a choice of using V5.3 which has bugs in that are now fixed in V6,
    or saying to my users live with it (where we shall get loads of flack)
    or looking for another editor of which I know Cutesoft is the best!
     
    Doh!
  •  08-15-2007, 9:52 AM 32493 in reply to 32492

    Re: IE6 incredibly slow

    AndyFel,
     
    There are something wrong. V6 should load two times faster than version 5.3.
     
    Can you run the following examples using IE7 and IE6, then let me know the result?

    http://cutesoft.net/asp/EnableAll.asp   (Cute Editor for ASP)

    http://phphtmledit.com/EnableAll.php  (Cute Editor for PHP)

    For IE 6, you can go to Tools>>Internet Options>> Security>> set it to default level. Then try again.
     
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  08-15-2007, 4:24 PM 32513 in reply to 32492

    Re: IE6 incredibly slow

    Can you give us a URL to try that demonstrates the problem? We can try using IE6 on a couple of machines here at the office.
  •  08-16-2007, 10:28 AM 32534 in reply to 32493

    Re: IE6 incredibly slow

    Hi
     
    Have tried all.
     
    For IE6. The pages show in about 5secs, but it then takes about 50 secs to download all 100 files.
    For IE7. The pages show in about 5secs and its finished.
    I did a similar test at home a couple of days ago using IE6 and it took about 30 secs to download all 100 files.
    With V5.3 on our test site, the page show in about 5 secs and thats it under all versions.
     
    Reset the security and the timings were the same.
     
    I used a stopwatch and tried 5 times, give or take 5 secs either side they were pretty consistent. All the versions were the about the same timings.
     
    Strange thing is when you do a refresh the toolbar shows fine, but it still insists on downloading the files. So its as if the files have been found in the cache and shown, but still downloads for some reason. Problem is it wont let us edit until all the files are downloaded.
     
    On an even slower network which some of our soldiers use (dial up) waiting for 100 files takes forever. They were happy before because it only took about 20 secs to download over a modem before. They now wait minutes.
     
    Someone else did mention having to wait for 100 files to download, so surely it cant just be us......
     
  •  08-16-2007, 12:14 PM 32540 in reply to 32534

    Re: IE6 incredibly slow

    There's nothing can be done about your problem unless you can give as a website we can test and confirm what you are saying.
  •  08-17-2007, 5:18 AM 32555 in reply to 32540

    Re: IE6 incredibly slow

    Our website is an internal MOD one which cannot be accessed by the internet.
     
    We can replicate the problem on the cutesoft demo, all the timings i specified were for the three demo urls adam gave, its not just our site. Except for the V5.3 which was from a testsite of ours where we have rolled back the code.
     
    I have also asked friends who still use IE6 to access your demo pages and they all get similar response times, i.e. the initial page appears in about 5 secs and then the 100 files finally download anywhere between 20-70 secs. All these were timings on http://cutesoft.net/example/general.aspx.
     
    Thinking about the code I am assuming all these 100 files are being bottlenecked thru load.ashx. I fail to see how loading an image thru a handler is any quicker than accessing it directly via a URL where IIS can do things far quicker and efficiently than pumping it via dotnet. Also it appears IE6 has problem caching these files.
     
    A question.... These 100 files its downloading, are they all the images on the toolbar? I was assuming they were, but maybe they are something different? In fact the url in the status bar never changes, the file count decreases, but the URL always says load.ashx?type=image&file=blank2020.png.
     
    Maybe its a small bug that only shows on IE6? Or more likely its a bug with IE6 which needs working round....
  •  08-17-2007, 9:47 AM 32559 in reply to 32555

    Re: IE6 incredibly slow

    http://cutesoft.net/example/general.aspx loads immediately in IE6 on 3 Win2x computers running IE6 here in the offfice. So the problem is either a setting on your computer or the ISP host's caching model or somewhere else, but it's definitely nothing to do with CE.
     
    Ask a friend operating in another state to test as well, ensuring first that friend doesn't use the same ISP host as you do. I think you will find the load times normal and reload times fully cached.
  •  08-20-2007, 8:39 AM 32598 in reply to 32559

    Re: IE6 incredibly slow

    That must be at least 4 different ISPs that are doing something different then...... Like I said I have had other people try it.
     
    It wouldnt surprise me with the MOD network being different tho. BUT V5.3 was/is ultra fast compared to V6 on IE6 so its not as if it could not be fixed. I get sick and tired of the "it works on our network....". If there is a problem on one network then there is bound to be a problem on another network, which I have already shown by getting other people to try it. Someone else on this thread has also said its downloading 100+ files.
     
    However I have been doing some digging.....
     
    I mentioned before the URL in the status bar is always saying loading load.ashx?type=image&file=blank2020.png. I was guessing that IE6 was incorrectly reporting it, but i am now convinced that it is downloading this one image 90+ times. I hope to prove this by using etherreal soon.
     
    I cannot find a reference to blank2020.png in any HTML but did find it in IE_Loader\loader.js. This is leading me to wonder how your code is loading this file. If you could make it only load it once then these 90+ files go away. I am now thinking that all the graphics are being cached just not this one for some reason.
     
    So Adam any chance you can have a quick look at your code to see why blank2020.png is being loaded 90+ times?
     
    Thanks
     
  •  08-28-2007, 4:50 AM 32978 in reply to 32598

    Re: IE6 incredibly slow

    Thanks for the lack of help guys......
     
    Anyway I have solved the problem. A week off helped and came back with fresh ideas.
     
    Remember that file blank202.png that was being downloaded 90+ times, well I thought why dont I change it to a gif!
    I found there was already a gif of that filename already that was a third the size of the png.
    So i edited
     
    Scripts\IE_Loader\Loader.js and changed blank2020.png to blank2020.gif
     
    and now its ultra fast again!
     
    So 2 questions.
    1. Why are using a png and not the gif.
    2. Can you change this in your next release so I dont need to keep fixing your file?
     
    Thanks 
Page 1 of 2 (25 items)   1 2 Next >
View as RSS news feed in XML
Powered by Community Server (Commercial Edition), by Telligent Systems