Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Embedding messenger into page not working correctly

Last post 11-16-2012, 8:56 AM by PeterGregory. 4 replies.
Sort Posts: Previous Next
  •  11-16-2012, 4:33 AM 75267

    Embedding messenger into page not working correctly

    Hi,

     

    I am trying to embed the messenger into a page however it's not working properly. It only shows the "web-messenger-banner.gif" banner and nothing else i.e it doesn't appear to be loading contacts, profile info, etc.

     

    This is the code I am using:

     

    <%@ Register TagPrefix="CuteChat" TagName="EmbedMessenger" Src="~/CuteSoft_Client/CuteChat/EmbedMessenger.ascx" %>  
    <div class="chat">
       <CuteChat:EmbedMessenger id="EmbedMessenger1" runat="server"></CuteChat:EmbedMessenger>
    </div>

    Can anyone help?

     

    Thanks

    Pete.

  •  11-16-2012, 6:37 AM 75268 in reply to 75267

    Re: Embedding messenger into page not working correctly

    Hi PeterGregory ,

     

    Your code has no problem. To use the CuteMessenger embed mode, you need to login the site first, then access the embed messenger page.

     

    If allow, please show me your embed messenger page url, so we can check it for you.

     

    Regards,

     

    Ken

  •  11-16-2012, 7:06 AM 75269 in reply to 75268

    Re: Embedding messenger into page not working correctly

    I can't really show you the website as it's on an internal developlment server which isn't public facing. :-(

     

    I'm definately logged in - it uses windows authentication. And I can tell I'm logged in when I go to open up the messenger as a pop up.

     

    The javascript call ("Chat_OpenMessenger()") to load the messenger within the page also works fine. It's just that embed control does not seem to work at all.

     

    I haven't changed "EmbedMessenger.ascx" file at all either.

     

    It literally just shows that banner and nothing else. I've added the embed control to a blank page just for test purposes and it still doesn't work.

     

    Any other suggestions??

     

    Thanks

    Pete.

  •  11-16-2012, 8:23 AM 75270 in reply to 75269

    Re: Embedding messenger into page not working correctly

    Hi PeterGregory ,

     

    Can you post a screenshot to show how it looks like on your site? Did you get any javascript error with the page?

     

    Below is the embed mode on my end.

     

     

     

    Regards,

     

    Ken

  •  11-16-2012, 8:56 AM 75271 in reply to 75270

    Re: Embedding messenger into page not working correctly

    I tested it in Internet Explorer and found out I was getting a JS error. I figured it was something to do with the XML folder that I was playing around with, so I re-copied all the files over and it's now working. Thanks for pointing that out! :-)
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.