Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Code Snippet configuration

Last post 10-08-2012, 9:16 AM by Kenneth. 1 replies.
Sort Posts: Previous Next
  •  09-28-2012, 11:18 AM 74817

    Code Snippet configuration

    I have a code snippet that fails to insert the code. I have determined that 2 areas of the code snippet seem to be potential causes of the problem, (1) the onclick javascript and (2) the style setting for the IMG tag.

    The snippet is as follows and is a simple Highslide invocation to load an iframe with an image and the IMG background URL simply places a play button the the img. 

     

    <a onclick="return hs.htmlExpand(this, { objectType: 'iframe', width: 540, height:380} )" href="../cxvideo.php?video=testvideo">
    <img src="/x/videoredplaysmall.png" style="border:1px solid #1538a7; background:URL('/x/testvideoThumb.jpg') center center black;" alt="" /></a> 

     

    If I remove both of these the snippet works.

    If I insert the exact same code into the HTML panel it works perfectly.

    I tried the false setting for the script inject security setting but it made no difference

     

    Any suggestions would be appreciated as ajax facilities are essential on my application so these snippets become more important each day and i like the cuteeditor a lot for its flexibility

  •  10-08-2012, 9:16 AM 74910 in reply to 74817

    Re: Code Snippet configuration

    Hi FrankM,

     

    Please try the way below

     

    1. Open file \cuteeditor_files\include_CuteEditor.php 

     

    2. Find section below

     

     $s=$s."<span val='".$v."' html='".$h."' txt='".$t."'></span>";

     

    3. Change it to

     

    $s=$s."<span val=\"".$v."\" html='".$h."' txt='".$t."'></span>"; 

     

    Regards,

     

    Ken 

View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.