Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Permission denied : CuteWebUI_Uploader_Resource.axd

Last post 09-06-2012, 1:18 AM by sansindia85. 4 replies.
Sort Posts: Previous Next
  •  08-28-2012, 1:09 AM 74490

    Permission denied : CuteWebUI_Uploader_Resource.axd

    I use IIS 7.5 and ASP.Net 4.0 web forms.

    In production server, I get suddenly this error. Is there any solution?

     

     

  •  08-28-2012, 8:42 AM 74495 in reply to 74490

    Re: Permission denied : CuteWebUI_Uploader_Resource.axd

    Hi sansindia85,

     

    Do you get the same problem with the example page below?

    If yes, please send me the test page url, I will check it and get back to you as soon as possible.

    1. <%@ Page Language="C#" %>  
    2.   
    3. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">  
    4. <html xmlns="http://www.w3.org/1999/xhtml">  
    5. <head id="Head1" runat="server">  
    6.     <title>example</title>  
    7. </head>  
    8. <body>  
    9.     <form id="form1" runat="server">  
    10.         <CuteWebUI:Uploader ID="Uploader1" runat="server">  
    11.         </CuteWebUI:Uploader>  
    12.     </form>  
    13. </body>  
    14. </html>  

    Try set the "TempDirectory for the uploader control, ensure that your site has the write/read permission of the folder you set for.

     

     <CuteWebUI:Uploader ID="Uploader1" runat="server" TempDirectory="~/mytemp">
            </CuteWebUI:Uploader>
     

     

    Regards,

     

    Ken 

  •  08-28-2012, 9:45 AM 74500 in reply to 74495

    Re: Permission denied : CuteWebUI_Uploader_Resource.axd

    Hi Ken,

     

    Thanks for the reply.

    In my present code:

     

    For a "Default.aspx" file (Source View), there is no "TempDirectory" property is present  for ajax uploader control . But in 

    "Default.aspx" file (Design View), right click the ajax uploader control and view properties, the TempDirectory property is 

    set to "~/UploaderTemp". <-- Is this inconsistency between the Source View and Design View creates the problem?

     

    Administrator is logged into the OS. The AppPool process model identity is set to "LocalSystem". The "UploaderTemp" folder is present in the path "C:\inetpub

    \wwwroot\MigrationTools Web Site\MigrationToolsWebApplication\UploaderTemp". The UploaderTemp folder properties security tab -> Group or User Name for the user "System" and "administrator" is set to full access.  Is these settings are fine or any new group or user has to be added?

     

    Regards,

    sans. 

  •  08-29-2012, 7:41 AM 74508 in reply to 74500

    Re: Permission denied : CuteWebUI_Uploader_Resource.axd

    Hi sansindia85,

     

    You can set the TempDirectory in the control target like what I sent. Then give the full permission to user "Everyone" and try again.

     

    And please create an empty page which only contains the Ajax Uploader control. Does it get the same error?

     

    Regards,

     

    Ken 

  •  09-06-2012, 1:18 AM 74580 in reply to 74508

    Re: Permission denied : CuteWebUI_Uploader_Resource.axd

    Thanks Ken for the reply. I applied the setting "Every One". Will come back to you If I get the error again.
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.