Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

[Urgent]: CuteEditor JS setHTML() behaving differently with IE & Chrome

Last post 08-13-2012, 4:44 AM by Kenneth. 7 replies.
Sort Posts: Previous Next
  •  01-20-2012, 12:27 AM 72753

    [Urgent]: CuteEditor JS setHTML() behaving differently with IE & Chrome

    Hello,
    I am having problem while setting html to cute editor. I am using cute editor(v 6.6) in jquery overlay popup. The popup will open when user hit either Add or Edit buttons.
    1. In case of Add I am setting cute editor value with setHTML(" ") , at first attempt this will raise an error as "Uncaught TypeError: Object #<HTMLTableElement> has no method 'SetHTML'". 
    2. In case of edit I am setting values from db, but getting the same error as point 1. Interesting thing is that when I will open javascript console (tools - javascript console) in chrome suddenly I see that the text is appeared in the editor (wired).
     
    Note: both above points working fine in IE 
    Please reply ASAP. 
  •  01-20-2012, 6:02 AM 72758 in reply to 72753

    Re: [Urgent]: CuteEditor JS setHTML() behaving differently with IE & Chrome

    Hi nrsharma,
     
    Can yo post a simple example page which can reproduce this issue? So we can check it for you.
     
    Regards,
     
    Ken 
  •  08-09-2012, 12:13 AM 74382 in reply to 72758

    Re: [Urgent]: CuteEditor JS setHTML() behaving differently with IE & Chrome

    Same issue error, I am using v6.3 and the error i am getting is 
    Uncaught TypeError: Object #<HTMLTableElement> has no method 'setHTML'  
    Is there any fix for this. Please let me know. 
    Filed under: ,
  •  08-09-2012, 9:54 AM 74387 in reply to 74382

    Re: [Urgent]: CuteEditor JS setHTML() behaving differently with IE & Chrome

    Hi swathiVajja,
     
    Do you get the same error with the example below? If it works, please create an example page which can reproduce this issue and post here, I will check it and get back to you as soon as possible.
     
    1. <%@ Page Language="C#" ValidateRequest="false" %>  
    2.   
    3. <%@ Register TagPrefix="CE" Namespace="CuteEditor" Assembly="CuteEditor" %>  
    4. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">  
    5. <html xmlns="http://www.w3.org/1999/xhtml">  
    6. <head runat="server">  
    7.     <title>example</title>  
    8. </head>  
    9. <body>  
    10.     <form id="form1" runat="server">  
    11.         <div>  
    12.             <CE:Editor ID="Editor1" runat="server">  
    13.             </CE:Editor>  
    14.         </div>  
    15.     </form>  
    16. </body>  
    17. </html>  
    Regards,
     
    Ken 
  •  08-10-2012, 12:37 AM 74396 in reply to 74387

    Re: [Urgent]: CuteEditor JS setHTML() behaving differently with IE & Chrome

    Hi Ken,
     
    Sorry  for misleading you. The actual issue is,In our project we are using tabstrip. On each tab i have one cute editor (say tab1,tab2).
     
    Tab1 is visible by default. 
     
    If i am trying to setHTML for the tab2(cute editor) which is not visible at that time . It's throwing me error.
     
    Weird thing is that, if i select  tab2, then select tab1, now if i tried to setHTML to tab2. It's working fine.
     
     Any thoughts on this.
     
    Thanks,
    Swathi 
    Filed under: , ,
  •  08-10-2012, 7:54 AM 74400 in reply to 74396

    Re: [Urgent]: CuteEditor JS setHTML() behaving differently with IE & Chrome

    Hi swathiVajja,
     
    Before the editor load complete, can't use the API of it. This is an old problem, we will fix it in the new version.
     
    I suggest you set the content when the user click on the tab, not on the page load. 
     
    Regards,
     
    Ken 
  •  08-13-2012, 1:15 AM 74409 in reply to 74400

    Re: [Urgent]: CuteEditor JS setHTML() behaving differently with IE & Chrome

    Hi Kenneth,
     
    Thanks for the reply. Is there any way that i can call intialize method from code. I tried making visible etc..
     
    Thanks,
    Swathi 
  •  08-13-2012, 4:44 AM 74413 in reply to 74409

    Re: [Urgent]: CuteEditor JS setHTML() behaving differently with IE & Chrome

    Hi swathiVajja,
     
    Yes, you can use API "CuteEditor_OnInitialized". It will fire after the editor load completed.
     
    <script>
    function CuteEditor_OnInitialized(editor)
    {
    }
    </script>
    Regards,
     
    Ken 
     
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.