Support forums
in

Configuring Spell Check

Last post 01-23-2014, 7:53 AM by Kenneth. 3 replies.
Sort Posts: Previous Next
  •  04-29-2011, 2:07 PM 67380

    Configuring Spell Check

    When I click the Spell Check button on the editor toolbar, I get the following error:
     
     A potentiall dangerous Request.Form value was detected from the client (CurrentText="my content here")
     
    My web app is using .Net Framework 4.0, if I change it to 3.5 the spell check opens fine.  I have tried turning off request validation for the app (instead of just the spell checker) and I get the same results. My app is leveraging a few .net 4.0 features, so this kind of gets in the way. Anyone found the right .NET 4.0 config for calling spell check from the editor?
  •  04-29-2011, 3:41 PM 67383 in reply to 67380

    Re: Configuring Spell Check

    Dear pdaltonmcsd,
     
    Please add the code below in your web.config and try again.
    <httpRuntime requestValidationMode=″2.0″ />
     
    Thank you for asking
  •  01-22-2014, 5:37 PM 78810 in reply to 67383

    Re: Configuring Spell Check

    Eric,

     

    I'm having the same issue, but we're running ASP.NET 3.5, which does not recognize  requestValidationMode as a valid attribute of httpRuntime. Any thoughts?

     

    -Tim 

  •  01-23-2014, 7:53 AM 78812 in reply to 78810

    Re: Configuring Spell Check

    Hi timwestover,

     

    For asp.net 3.5, you can do the setting below in your web.config.

     

       <pages validateRequest="false"></pages>

     

    Regards,

     

    Ken 

View as RSS news feed in XML
Powered by Community Server (Commercial Edition), by Telligent Systems