Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Error - Could not load file or assembly 'CuteEditor' or one of its dependencies. The system cannot find the file specified.

Last post 03-03-2008, 7:42 PM by quackmire. 6 replies.
Sort Posts: Previous Next
  •  02-25-2008, 1:33 PM 37336

    Error - Could not load file or assembly 'CuteEditor' or one of its dependencies. The system cannot find the file specified.

    Hi all,
     
    I think this topic has been covered before, but I can't find it right now.
     
    Been at this for 2 days.  I keep getting the following error when I try to view both CuteEditor and DotNetGallery demos on my own server:
     
     
    Line 1:  <%@ Page Language="C#"%>
    Line 2: <%@ Register TagPrefix="CE" Namespace="DotNetGallery" Assembly="DotNetGallery" %>
    Line 3: <html>
    Line 4:

    Source File: /douglasmcgregor.co.uk/DotNetGallery/demo.aspx    Line: 2

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'DotNetGallery' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

     
    I've got the CuteEditor.dll and the other relevent DotNetGallery in my Bin folder, and referenced them all, but no joy.  I've stopped the indexing service, and given the WINDOWS/Temp folder full read/write privileges.  I think what I need to do is get access to the configuration for the default files path, so how would I find this?
     
    Thanks
     
    Dug
     
  •  02-26-2008, 12:35 AM 37354 in reply to 37336

    Re: Error - Could not load file or assembly 'CuteEditor' or one of its dependencies. The system cannot find the file specified.

    Dug,
     
    Have you created a virtual directory for testing?
     
    Is this bin folder under a vitual directory or root?
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  03-03-2008, 1:47 PM 37504 in reply to 37354

    Re: Error - Could not load file or assembly 'CuteEditor' or one of its dependencies. The system cannot find the file specified.

    Thanks for the reply.
     
    My Bin folder is a virtual directory..... the CuteEditor.dll is in the Bin folder... my site layout is something as follows - root folder being douglasmcgregor.co.uk.......
     
     
    douglasmcgregor.co.uk
        App_Code
        App_Data
        Bin
        css
        CuteEditor
            Framework 1.x
            Framework 2.0
            Bin
            All the other CuteEditor folders....
        Cutesoft_Client
        highslide
        includes
        images
        js
        vb
     
     
    Still going with this problem and not getting anywhere fast!  From surfing the net it appears it might be a bug with .NET 2.0.
     
    Dug
     
           
  •  03-03-2008, 3:11 PM 37507 in reply to 37336

    Re: Error - Could not load file or assembly 'CuteEditor' or one of its dependencies. The system cannot find the file specified.

    Just clicked on the CuteEditor.dll in the browser and got a message saying "The specified procedure could not be found"..... what would this mean?
  •  03-03-2008, 3:49 PM 37515 in reply to 37504

    Re: Error - Could not load file or assembly 'CuteEditor' or one of its dependencies. The system cannot find the file specified.

    Dug,
     
    Which bin folder? You have to bin folders here.
     
    It looks like you didn't create a virtual directory.
     
    So please copy the DLL and license file to the bin folder of root.
     
    Keep me posted
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  03-03-2008, 5:18 PM 37517 in reply to 37515

    Re: Error - Could not load file or assembly 'CuteEditor' or one of its dependencies. The system cannot find the file specified.

    Oh wow, ok, it's working.  I had to reference the CuteEditor.dll in the root folder of my site.  That's a weight off my shoulders now!  The message I'm getting now is:
     
    A valid license cannot be granted for the type CuteEditor.Editor. Contact the manufacturer of the component for more information.
     
     
    Would this be that the trial has ended?
     

  •  03-03-2008, 7:42 PM 37518 in reply to 37517

    Re: Error - Could not load file or assembly 'CuteEditor' or one of its dependencies. The system cannot find the file specified.

    I was getting that until I put the .lic file in the bin folder of the application (not the root)  hth
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.