Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Updating full page causes error with Link tag

Last post 06-09-2008, 4:50 PM by LOGIKonline. 20 replies.
Page 1 of 2 (21 items)   1 2 Next >
Sort Posts: Previous Next
  •  08-07-2007, 5:43 AM 32216

    Updating full page causes error with Link tag

    The following tag when posted back to the server changes the <link tag to an invalid tag.  This breaks the page and it will not load.
     
    Before saving it back to server
      <link ID="pdCSS" RUNAT="Server" HREF="portal.css" TYPE="text/css" REL="stylesheet" />
     
    After saving it back to server
      <link ID="pdCSS" RUNAT="Server" HREF="portal.css" TYPE="text/css" REL="stylesheet"/ />
     
    Notice the double "/" at the end.  I tried making it </link> at the end - but it still does the same thing.
     
    Can you please instruct if there is a work around?
     
    D.
  •  08-07-2007, 10:08 AM 32229 in reply to 32216

    Re: Updating full page causes error with Link tag

    LOGIKonline,
     
     
    If you can't reproduce the problems, please download the latest build.
     
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  08-07-2007, 2:29 PM 32248 in reply to 32229

    Re: Updating full page causes error with Link tag

    I am abit confused why you sent me the example link.  I have it implemented now (the lastest build) and it causes the error.
     
    Here is the configuration - which I use to edit the page directly.

    sEditor.AutoConfigure = CuteEditor.AutoConfigure.Compact"
    sEditor.ShowHtmlMode =
    False
    sEditor.ShowEditMode = True
    sEditor.FullPage = True
    sEditor.ShowPreviewMode = False
    sEditor.ShowBottomBar = False
    sEditor.ThemeType = CuteEditor.ThemeType.Custom
    sEditor.ShowCodeViewToolBar =
    True
    sEditor.EditorWysiwygModeCss = CSSFile
    sEditor.EnableStripScriptTags =
    False
    sEditor.EditCompleteDocument = True
    sEditor.AllowEditServerSideCode = True
    sEditor.ActiveTab = CuteEditor.TabType.Code

  •  08-07-2007, 3:23 PM 32254 in reply to 32248

    Re: Updating full page causes error with Link tag

    I added the code to your sample... and it did the same error.  The bold line will double up the "/" (//>) like the above post says.
     
    <%@ Register tagPrefix="eActivated" Namespace="eActivated.Control" Assembly="CommonLOGIK" %>
    <%@ Register TagPrefix="radM" Namespace="Telerik.WebControls" Assembly="RadMenu" %>
    <%@ Page Language="vb" AutoEventWireup="false" Codebehind="Standard.aspx.vb" Inherits="CommonLOGIK.PageTemplate" %>
    <%@ Register TagPrefix="cspb" Namespace="Coalesys.PanelBar" Assembly="Coalesys.PanelBar" %>
    <%@ Register TagPrefix="AU" Namespace="ActiveUp.WebControls" Assembly="ActiveUp.WebControls" %>
    <html>
    <head>
     <%= PageDefs %>
     <link ID="pdCSS" RUNAT="Server" HREF="portal.css" TYPE="text/css" REL="stylesheet"/>
    </head>
    <body ID="pdBody" RUNAT="server" LEFTMARGIN="0" BOTTOMMARGIN="0" RIGHTMARGIN="0" TOPMARGIN="5" MARGINHEIGHT="0" MARGINWIDTH="0">
    <form RUNAT="server" ID="Form1">
     <table width="730"  border="0" cellpadding="4" cellspacing="0" align="center">
                          <tr>
                            <td id="cellonline" runat="Server" align="left" valign="top"></td>
                            <td id="cellregister" runat="Server" align="right" width="100%"  valign="top"></td>
                          </tr>
      </table>
    <table width="730" height="100%" align="center" cellpadding="0" cellspacing="0" class="borderoutline">
        <tr>
      <td align="center" valign="top" height="100%"><table width="730" height="100%" align="center" border="0" cellpadding="0" cellspacing="0">
       <tr>
        <td align="center" valign="top"><table width="730" border="0" cellpadding="0" cellspacing="0">
         <tr>
          <td  id="secmenux" runat="Server" align="right" valign="bottom" colspan="2"></td>
         </tr>
         <tr>
          <td width="400" align="left" valign="middle" id="celllogo" runat="Server"></td>
          <td width="338" align="right" valign="bottom"><table width="338"  border="0" cellpadding="4" cellspacing="0">
           <tr><td align="right" ><table width="338"><tr>
            <td id="search" runat="Server" align="right" valign="top" ></td></tr></table></td>
           </tr>
           <tr>
            <td id="secmenu" runat="Server" align="right" valign="bottom"></td>
           </tr>
          </table></td>
         </tr>
        </table></td>
       </tr>
       <tr>
        <td align="center"><table width="730" border="0" cellspacing="0" cellpadding="0">
         <tr>
          <td width="730" align="center"><radM:RadMenu id="MenuBar" runat="server"/></td>
         </tr>
        </table></td>
       </tr>
       <tr><AU:HtmlProtector id="Protector" runat="server"><td class="MainContainer" height="100%" align="center" valign="top"><table BORDER="0" CELLPADDING="0" WIDTH="100%" CELLSPACING="0" HEIGHT="100%">
        <tr VALIGN="top">
         <td ID="LeftPanex" RUNAT="server" WIDTH="0" align="center" NOWRAP></td>
         <td WIDTH="100%" ALIGN="left" VALIGN="top" HEIGHT="100%"><table ID="MainContainer" RUNAT="server" BORDER="0" CELLSPACING="0" WIDTH="100%" CELLPADDING="0" HEIGHT="100%">
          <tr id="HeaderRow" runat="server">
           <td WIDTH="100%" ALIGN="left" VALIGN="top"><table WIDTH="100%" CELLSPACING="0" CELLPADDING="0" BORDER="0">
            <tr VALIGN="top">
             <td ID="HeaderPane" VISIBLE="true" WIDTH="100%" RUNAT="server" VALIGN="top"></td>
            </tr>
           </table></td>
          </tr>
          <tr VALIGN="top">
           <td WIDTH="100%" ALIGN="left" VALIGN="top" HEIGHT="100%"><table WIDTH="100%" CELLSPACING="0" CELLPADDING="5" BORDER="0" HEIGHT="100%">
             <tr VALIGN="top">
              <td ID="LeftPane" VISIBLE="false" WIDTH="160" RUNAT="server" VALIGN="top" ALIGN="center" NOWRAP></td>
              <td ID="spLeftPane" VISIBLE="false" WIDTH="3" RUNAT="server" CLASS="vert_splitterx">&nbsp;</td>
              <td ID="ContentPane" VISIBLE="false" WIDTH="*" RUNAT="server" VALIGN="top" ALIGN="center"></td>
              <td ID="spRightPane" VISIBLE="false" WIDTH="3" RUNAT="server" CLASS="vert_splitterx">&nbsp;</td>
              <td ID="RightPane" VISIBLE="false" WIDTH="200" RUNAT="server" VALIGN="top"></td>
             </tr>
            </table></td>
          </tr>
          <tr id="FooterRow" runat="server">
           <td WIDTH="100%" ALIGN="left" VALIGN="top"><table WIDTH="100%" CELLSPACING="0" CELLPADDING="0" BORDER="0">
            <tr VALIGN="top">
             <td WIDTH="1">&nbsp;</td>
             <td ID="FooterPane" VISIBLE="true" WIDTH="100%" RUNAT="server" VALIGN="top"></td>
             <td WIDTH="1">&nbsp;</td>
            </tr>
           </table></td>
          </tr>
         </table></td>
       </tr></AU:HtmlProtector>   
      </table></td></tr>
     </table></td></tr>
    <tr id="AdminContainer" runat="server">
    <td align="center" valign="top">
    <table width="730" border="0" cellpadding="0" cellspacing="0" align="center">
     <tr>
      <td align="center" valign="top" id="bottomnav"  runat="Server"></td>
     </tr>
     <tr>
      <td align="center" valign="top" id="bottomfooter"  runat="Server"  bgcolor="#EEEEEE"></td>
     </tr>
     <tr>
      <td  bgcolor="#EEEEEE"><table WIDTH="100%" BORDER="0" CELLSPACING="0" CELLPADDING="4">
       <tr>
        <td CLASS="topsmllinks" VALIGN="middle" align="left"><a href="http://www.logikonline.com">Copyright 1999-2007 LOGIKonline Inc.</a></td>
        <td ID="cellExtras" RUNAT="server" CLASS="topsmllinks" ALIGN="center"><asp:CheckBox ID="DisplayView" VISIBLE="False" RUNAT="server" TEXT="View Definitions" AUTOPOSTBACK="True" />&nbsp;</td>
        <td ALIGN="right" VALIGN="middle" CLASS="topsmllinks">&nbsp;<asp:label ID="VersionMessage" RUNAT="server" /></td>
       </tr>
      </table></td>
     </tr>
    </table></td>
    </tr>
    </table>
    </form><script src="http://www.google-analytics.com/urchin.js" type="text/javascript">
    </script>
    <script type="text/javascript">
    _uacct = "UA-310415-4";
    urchinTracker();
    </script>
    </body>
    </html>
  •  08-08-2007, 12:03 AM 32260 in reply to 32254

    Re: Updating full page causes error with Link tag

    Im having the same problem hangs IE any suggestions
  •  08-08-2007, 8:09 AM 32282 in reply to 32254

    Re: Updating full page causes error with Link tag

    LOGIKonline,
     
    Which browser are you using?
     
    How did you test it in this example?
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  08-08-2007, 9:09 AM 32293 in reply to 32282

    Re: Updating full page causes error with Link tag

    Version 6 of your cuteditor in IE and FF is hanging the browser on every content that contains a LINK tag for CSS
    or a broken IMG src reference. In IE the status bar displays downloading then it freezes.
     
    Is their a way to strip link tags for the css references also why does it hang trying to download a non existent img src?
  •  08-08-2007, 9:12 AM 32294 in reply to 32293

    Re: Updating full page causes error with Link tag

    jacktubbs:
    Version 6 of your cuteditor in IE and FF is hanging the browser on every content that contains a LINK tag for CSS
    or a broken IMG src reference. In IE the status bar displays downloading then it freezes.
     
    Is their a way to strip link tags for the css references also why does it hang trying to download a non existent img src?
     
    jacktubbs,
     
    This bug has been fixed in the recent build.
     
    Can you try the following examples?
     
     
     
    If you can not reproduce the problems, please download the latest build.
     
     
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  08-08-2007, 9:32 AM 32296 in reply to 32294

    Re: Updating full page causes error with Link tag

    I copied the new cuteeditor.dll to the server didnt solve the problem do I need to extract the entire zip or just the cuteditor.dll?
  •  08-08-2007, 9:38 AM 32297 in reply to 32282

    Re: Updating full page causes error with Link tag

    I pasted the above text into your editor sample link you sent me.  When I do - it doubles up the "/" and will crash the browser.
     
    Now - to clarify some.  It does not crash your editor or the browser while editing.  It crashes the browser from the resulting change (remember - we are using your editor to manage our code)  Therefore, the resulting change will make invalid code with ASP.NET will crash when it runs.
     
    I put a hack into my code

    sEditor.Text = sEditor.Text.Replace("/ />", "/>")

    But not sure it catches all changes your editor makes.  I really need this resolved.  I am using version 6.0.0.0.  Is this the latest?
     
    regards,
    Dave
     
    I am using IE 7.0
  •  08-08-2007, 9:42 AM 32298 in reply to 32296

    Re: Updating full page causes error with Link tag

    jacktubbs:
    I copied the new cuteeditor.dll to the server didnt solve the problem do I need to extract the entire zip or just the cuteditor.dll?
     
    Update all files under CuteSoft_Client\CuteEditor\Scripts directory.
     
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  08-08-2007, 9:43 AM 32299 in reply to 32298

    Re: Updating full page causes error with Link tag

    I will try thanks
  •  08-09-2007, 12:49 PM 32357 in reply to 32298

    Re: Updating full page causes error with Link tag

    were you able to reproduce the issue I was originally pointing out?
  •  08-15-2007, 11:45 AM 32501 in reply to 32298

    Re: Updating full page causes error with Link tag

    Why are you not responding Adam?
     
    The issue the other guy was having is not related.
  •  08-15-2007, 12:03 PM 32503 in reply to 32501

    Re: Updating full page causes error with Link tag

    LOGIKonline,
     
    This issue is resolved. Please try the following example:
     
     
    If you don't agree, please provide more information to show this problem.
     
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  08-16-2007, 10:40 PM 32552 in reply to 32503

    Re: Updating full page causes error with Link tag

    Adam
    It is not resolved. 
     
    If you paste the above text, as I instructed, it will produce the error.  Are you not reading what I write?  I am taking the time to report the error and provide a sample with explanation which is repeatable.
     
    Once again:
     
    I pasted the above text into your editor sample link you sent me.  When I do - it doubles up the "/" on the <link> tag.
     
    Now - to clarify some.  It does not crash your editor or the browser while editing.  It crashes the browser from the resulting change (remember - we are using your editor to manage our code)  Therefore, the resulting change will make invalid code with ASP.NET will crash when it runs.
     
    I put a hack into my code

    sEditor.Text = sEditor.Text.Replace("/ />", "/>")

    But not sure it catches all changes your editor makes.  I really need this resolved.  I am using version 6.0.0.0.  Is this the latest?
     
     
    D
  •  08-17-2007, 11:02 AM 32562 in reply to 32552

    Re: Updating full page causes error with Link tag

    David,
     
    I tried you example code using IE 6 and Firefox. And I can't reproduce the problem. WHich browser are you using?
     
    IE6:
     
    <LINK id=pdCSS href="portal.css" type=text/css rel=stylesheet RUNAT="Server">
     
    Firefox:
     
    <link id="pdCSS" runat="Server" href="portal.css" type="text/css" rel="stylesheet" />

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  08-17-2007, 11:51 AM 32568 in reply to 32552

    Re: Updating full page causes error with Link tag

    Hi,
     
    I had reported this bug earlier - it's because of the "rel=stylesheet" setting if I recall correctly. Try removing those words and testing again.
     
    Here's some references:
     
    http://cutesoft.net/forums/thread/31683.aspx
    http://cutesoft.net/forums/thread/31681.aspx
     
    Adam fixed the problem and our current stuff works fine when I pasted your code into our editor. Are you sure you are using the latest download?
  •  08-29-2007, 2:06 PM 33054 in reply to 32568

    Re: Updating full page causes error with Link tag

    I am using the latest version... both in my app as well as your online sample which Adam linked me too (on your site).  I cannot control my user's actions (since they are using the editor to edit their own pages)
     
     
    I am using IE 7.0 - and double verified that it occurs with Firefox as well.
     
    Before:
     <link ID="pdCSS" RUNAT="Server" HREF="portal.css" TYPE="text/css" REL="stylesheet"/>
     
    After:
     <link ID="pdCSS" RUNAT="Server" HREF="portal.css" TYPE="text/css" REL="stylesheet"/ />
     
    D.
  •  06-07-2008, 5:43 PM 41240 in reply to 33054

    Re: Updating full page causes error with Link tag

    The last post - June 6...  did not resolve this.
     
    In fact, your solution is to strip the tag completely - which is not a fix - It now breaks the solution I offer, as now the tag no longer is present when my clients update the page.
     
    Please resolve this immediately.
Page 1 of 2 (21 items)   1 2 Next >
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.