Support forums
in

Cute Editor FIX - PostBackCommand no longer firing

Last post 06-16-2010, 11:55 AM by Adam. 4 replies.
Sort Posts: Previous Next
  •  05-23-2007, 9:26 AM 29973

    Cute Editor FIX - PostBackCommand no longer firing

    If you have any code in your Page.Load or Page.Init event that modifies the EditorWysiwygModeCss property, the PostBackCommand will no longer fire.  Place the code in the Editor.Init event instead to avoid this problem.
  •  05-03-2010, 9:47 PM 60649 in reply to 29973

    Re: Cute Editor FIX - PostBackCommand no longer firing

    Hi Judge,
     
    We are investigating this issue and will get back to you as soon as possible.
     
    Regrds,
     
    Ken
  •  06-10-2010, 12:44 AM 61656 in reply to 60649

    Re: Cute Editor FIX - PostBackCommand no longer firing

    Hi Judge,
     
    Try
     
    1. <%@ Page Language="C#" %>   
    2.   
    3. <%@ Register Namespace="CuteEditor" Assembly="CuteEditor" TagPrefix="CE" %>   
    4. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">   
    5.   
    6. <script runat="server">      
    7.     protected override void OnLoad(EventArgs e)   
    8.     {   
    9.         if (!IsPostBack)   
    10.         {   
    11.             editor1.EditorWysiwygModeCss = "~/empty.css";   
    12.         }   
    13.   
    14.         base.OnLoad(e);   
    15.     }   
    16.     protected void editor1_PostBackCommand(object sender, CommandEventArgs e)   
    17.     {   
    18.         label1.Text = editor1.Text;   
    19.     }   
    20. </script>   
    21.   
    22. <html xmlns="http://www.w3.org/1999/xhtml">   
    23. <head id="Head1" runat="server">   
    24.     <title>Untitled Page</title>   
    25. </head>   
    26. <body>   
    27.     <form id="form1" runat="server">   
    28.         <div>   
    29.             <CE:Editor ID="editor1" runat="server" OnPostBackCommand="editor1_PostBackCommand">   
    30.             </CE:Editor>   
    31.             <asp:Label ID="label1" runat="server"></asp:Label>   
    32.         </div>   
    33.     </form>   
    34. </body>   
    35. </html>  
    Regards,
     
    Ken
  •  06-16-2010, 11:55 AM 61823 in reply to 29973

    Re: Cute Editor FIX - PostBackCommand no longer firing

View as RSS news feed in XML
Powered by Community Server (Commercial Edition), by Telligent Systems