Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Images not being displayed

Last post 10-29-2010, 1:46 PM by GCB. 16 replies.
Sort Posts: Previous Next
  •  10-28-2010, 12:09 PM 64759

    Images not being displayed

    Hello,
     
    I just installed DNG 3.1 and am attempting to convert my website (not public) from version 1.  The site is compiling and running correctly.  DNG is finding the image directory (GalleryFolder) because I can see the thumbnails and config files being created.  It is also finding its files directory (GalleryClient) because when I put in a different path it gives an exception, when I put in the correct one it runs. 
     
    However, it is displaying the grey background and thumbnail slots for the gallery, but it is not displaying any of the images.  See image below.
     
     
    Gary  
  •  10-28-2010, 2:13 PM 64761 in reply to 64759

    Re: Images not being displayed

    Dear GCB,
     
    Please  copy all photos of your old gallery folder to the new gallery folder. 
    DotNetGallery will create the thumbnail automatically.
    If this doesn't work, please let me know.
     
    Thank you for asking
     
     
  •  10-28-2010, 2:40 PM 64762 in reply to 64761

    Re: Images not being displayed

    Eric,
     
    Thanks for replying.  As I said, I already copied the files and DNG did create the thumnails.  It's just not displaying them on the web page. 
  •  10-28-2010, 2:47 PM 64763 in reply to 64762

    Re: Images not being displayed

    Here is an image of the images directory.  As you can see, the thumbnails are being created. They are just not being displayed.
     
     
  •  10-28-2010, 3:12 PM 64764 in reply to 64763

    Re: Images not being displayed

    Here is the runtime code that DotNetGallery is inserting into my web page.  I am setting GalleryClient to "~/U_DotNetGallery_Files/".
     
    Again, DNG is not displaying any of the images and is not responding to mouse actions.  
     
     
        <script type='text/javascript' src='~/U_DotNetGallery_Files/Load.ashx?type=culture&culture=en-US'></script>
        <script type='text/javascript' src='~/U_DotNetGallery_Files/Core/GalleryLibrary.js'></script>
        <script type='text/javascript' src='~/U_DotNetGallery_Files/Share/LibraryExt.js'></script>
        <script type='text/javascript' src='~/U_DotNetGallery_Files/Core/GalleryMenu.js'></script>
        <script type='text/javascript' src='~/U_DotNetGallery_Files/Core/GalleryBrowser.js'></script>
        <script type='text/javascript' src='~/U_DotNetGallery_Files/Layout/SlideShow/Code.js'></script>
        <script type='text/javascript' src='~/U_DotNetGallery_Files/Slider/NewWin/Code.js'></script>
        <script type='text/javascript' src='~/U_DotNetGallery_Files/Viewer/LightBox/Code.js'></script>
        <script type='text/javascript' src='~/U_DotNetGallery_Files/Popup/Default/Code.js'></script>
        <script type='text/javascript' src='~/U_DotNetGallery_Files/Theme/Classic/Code.js'></script>
        <link rel='stylesheet' href='~/U_DotNetGallery_Files/Gallery.css' />
        <link rel='stylesheet' href='~/U_DotNetGallery_Files/Theme/Classic/Style.css' />
        <link rel='stylesheet' href='~/U_DotNetGallery_Files/Layout/SlideShow/Style.css' />
        <link rel='stylesheet' href='~/U_DotNetGallery_Files/Viewer/LightBox/Style.css' />
        <div id="ctl00_MasterContent_Gallery1" style="height: 360px; width: 535px;">
            <!--Start Layout Template 'SlideShow'-->
            <div id='dng_container' class="GalleryLayout" style="background-color: #666666; border: solid 1px #666666;
                width: 100%; height: 100%; position: relative;">
                <div id="dng_photo1" style='position: absolute; top: 0px; left: 0px; width: 100%;
                    text-align: center; background-color: #666666;'>
                </div>
                <div id="dng_photo2" style='position: absolute; top: 0px; left: 0px; width: 100%;
                    text-align: center; background-color: #666666;'>
                </div>
                <div id="dng_topinfo" style='position: absolute; top: 0px; left: 0px; width: 100%;
                    height: 48px; background-color: #666666; display: none'>
                    <div style="text-align: left; height: 24px; background-color: #000000">
                        <div id="dng_topinfoindex" style="padding: 4px">
                            Name</div>
                    </div>
                    <div style="text-align: left; height: 24px; background-color: #333333">
                        <div id="dng_topinfoname" style="padding: 4px">
                            Index</div>
                    </div>
                </div>
                <table id="dng_toolbar" border="0" cellspacing="0" cellpadding="0" style='position: absolute;
                    left: 0px; bottom: 0px; width: 100%; height: 30px; background-color: #333333;'>
                    <tr>
                        <td style='width: 60px; text-align: right; vertical-align: middle;'>
                            <img class='BlackSliderButton' id="dng_btn_config" style='width: 16px; height: 16px' />
                            <img class='BlackSliderButton' id='dng_btn_prev' style='width: 16px; height: 16px' />
                        </td>
                        <td style='background-color: black; border: solid 3px #333333;' id='dng_tabcontainer'>
                        </td>
                        <td style='width: 90px; vertical-align: middle;'>
                            <img class='BlackSliderButton' id="dng_btn_next" style='width: 16px; height: 16px' />
                            <img class='BlackSliderButton' id="dng_btn_play" style='width: 16px; height: 16px' />
                            <img class="BlackSliderButton" id="dng_btn_slider" style='width: 16px; height: 16px'
                                onclick="GalleryBrowser.Execute(this,'ShowSlider');return false;" />
                        </td>
                    </tr>
                </table>
            </div>
            <!--End Template-->
            <script type='text/javascript'><!--
                var GalleryAjaxData = { Controls: [
    { ClientID: 'ctl00_MasterContent_Gallery1', UniqueID: 'ctl00$MasterContent$Gallery1', Methods: [{ Name: 'UploadFiles', ParameterCount: 1 }, { Name: 'CreateCategory', ParameterCount: 1 }, { Name: 'DeleteCategory', ParameterCount: 1 }, { Name: 'DeletePhoto', ParameterCount: 2 }, { Name: 'UpdateCategory', ParameterCount: 2 }, { Name: 'UpdatePhoto', ParameterCount: 4 }, { Name: 'GetAllCategoryData', ParameterCount: 0 }, { Name: 'GetCategoryData', ParameterCount: 1 }, { Name: 'AddCategoryComment', ParameterCount: 3 }, { Name: 'AddPhotoComment', ParameterCount: 4 }, { Name: 'DeleteCategoryComment', ParameterCount: 2 }, { Name: 'DeletePhotoComment', ParameterCount: 3}] }
    ]
                };

    --></script>
            <script type='text/javascript' src='~/U_DotNetGallery_Files/Core/GalleryAjax.js'><!-- --></script>
        </div>
        <script type='text/javascript'>        var thegallerybrowser = new GalleryBrowser(
    { ClientID: 'ctl00_MasterContent_Gallery1', UniqueID: 'ctl00$MasterContent$Gallery1', Folder: '~/U_DotNetGallery_Files/', LoadHandler: 'Load.ashx', Theme: 'Classic', Culture: 'en-US', Layout: 'SlideShow', Slider: 'NewWin', Viewer: 'LightBox', Popup: 'Default', Editor: 'Explorer', LogonUserID: null, LogonUserName: null, AllowEdit: null, AllowPostComment: null, AllowShowComment: 1
    , ScriptOption: {}
    , Categories: [{ 'Title': null, 'CategoryID': null, 'Description': null, 'Photos': [{ 'PhotoID': 'IMG_2244w.jpg', 'Title': 'IMG_2244w.jpg', 'Comment': '', 'Size': 208124, 'Height': 427, 'Time': new Date(1277224998064), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2244w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2244w.jpg', 'Width': 640 }, { 'PhotoID': 'IMG_2309w.jpg', 'Title': 'IMG_2309w.jpg', 'Comment': '', 'Size': 248209, 'Height': 427, 'Time': new Date(1277224972111), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2309w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2309w.jpg', 'Width': 640 }, { 'PhotoID': 'IMG_2317w.jpg', 'Title': 'IMG_2317w.jpg', 'Comment': '', 'Size': 198615, 'Height': 427, 'Time': new Date(1277224950908), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2317w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2317w.jpg', 'Width': 640 }, { 'PhotoID': 'IMG_2325w.jpg', 'Title': 'IMG_2325w.jpg', 'Comment': '', 'Size': 180503, 'Height': 427, 'Time': new Date(1277224925361), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2325w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2325w.jpg', 'Width': 640 }, { 'PhotoID': 'IMG_2347w.jpg', 'Title': 'IMG_2347w.jpg', 'Comment': '', 'Size': 162847, 'Height': 427, 'Time': new Date(1277224898860), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2347w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2347w.jpg', 'Width': 640 }, { 'PhotoID': 'IMG_2355w.jpg', 'Title': 'IMG_2355w.jpg', 'Comment': '', 'Size': 181478, 'Height': 427, 'Time': new Date(1277224878470), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2355w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2355w.jpg', 'Width': 640 }, { 'PhotoID': 'IMG_2378w.jpg', 'Title': 'IMG_2378w.jpg', 'Comment': '', 'Size': 289039, 'Height': 427, 'Time': new Date(1277224849344), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2378w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2378w.jpg', 'Width': 640 }, { 'PhotoID': 'IMG_2397w.jpg', 'Title': 'IMG_2397w.jpg', 'Comment': '', 'Size': 286135, 'Height': 427, 'Time': new Date(1277224824922), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2397w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2397w.jpg', 'Width': 640 }, { 'PhotoID': 'IMG_2446w.jpg', 'Title': 'IMG_2446w.jpg', 'Comment': '', 'Size': 234612, 'Height': 427, 'Time': new Date(1277224802797), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2446w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2446w.jpg', 'Width': 640 }, { 'PhotoID': 'IMG_2462w.jpg', 'Title': 'IMG_2462w.jpg', 'Comment': '', 'Size': 241097, 'Height': 427, 'Time': new Date(1277224760577), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2462w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2462w.jpg', 'Width': 640 }, { 'PhotoID': 'IMG_2517w.jpg', 'Title': 'IMG_2517w.jpg', 'Comment': '', 'Size': 192129, 'Height': 426, 'Time': new Date(1277224717748), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2517w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2517w.jpg', 'Width': 640 }, { 'PhotoID': 'IMG_2528w.jpg', 'Title': 'IMG_2528w.jpg', 'Comment': '', 'Size': 231357, 'Height': 427, 'Time': new Date(1277224691091), 'CategoryID': null, 'Thumbnail': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2528w.thumbnail.jpg', 'Url': '/HFTPTest/Images/Home/Events/HITEC/HITEC10Gallery/IMG_2528w.jpg', 'Width': 640}]}]
    });</script>

  •  10-28-2010, 3:18 PM 64765 in reply to 64764

    Re: Images not being displayed

    Dear GCB,
     
    Can you send a temp ftp access to eric@cutesoft.net?  I will check this issue.
     
    Thank you for your business
  •  10-28-2010, 4:08 PM 64766 in reply to 64765

    Re: Images not being displayed

    I cannot place the test code on a public site as doing so will break our production web site photo galleries, which use DNG version 1.   
     
    Please don't give up on me.  Let me know what you would try to fix it and I'll try it here.
     
    Thanks.  
  •  10-28-2010, 4:44 PM 64768 in reply to 64766

    Re: Images not being displayed

    I copied the Default.aspx from your demo to my website.  The only thing I changed in it was I removed your banner and then changed GalleryClient and GalleryFolder to point to the correct locations on my site.  I created a new test folder of images and then ran the page in the debugger.  It complied with no errors and ran.  It created the thumbnails, but the gallery control is still coming up empty.  
  •  10-28-2010, 10:34 PM 64776 in reply to 64768

    Re: Images not being displayed

    HI GCB,
     
    Do you get the same issue on our download package demo(Do not integration with your site, just test the demo only)? 
     
    Please test our online demo http://www.cutesoft.net/ASP.NET+Image+Gallery/ ? Can you see the image? Do you have the same issue as your site?
     
    check the permission, make sure your site have the write/read permission of this folder.
     
    Keep me posted.
     
    Regards,
     
    ken 
  •  10-29-2010, 8:51 AM 64788 in reply to 64776

    Re: Images not being displayed

    Yes, the demo works fine by itself. 
     
    What folder are you talking about?  Obviously the image folder has write permissions because the thumbnails are being created.  
     
    Could this have anything to do with versions. I am using .NET 3.5.  
     
     
    I am going to trim down my website to a smaller version and zip it up and send it to you.  Where should I send it? 
     
    Thanks.  
     
  •  10-29-2010, 9:07 AM 64789 in reply to 64788

    Re: Images not being displayed

     
    Yes, I trimmed down my website to contain only one page - the Gallery.aspx copied from your demo.  The web.config is my web.config with no changes.  This website is zipped and attached to this post.   Gallery.aspx should be set as the start page. 
     
    Note that the DNG control does not display any pictures.  
     
     
     
     
  •  10-29-2010, 9:24 AM 64790 in reply to 64789

    Re: Images not being displayed

    Okay, I seem to see the problem.  
     
    As you can see if you test my code, the problem seems to be caused by the fact that I am setting GalleryClient to something other than the default.  Either I'm doing it wrong or you have a bug. 
     
    Which is it?  
  •  10-29-2010, 9:43 AM 64791 in reply to 64790

    Re: Images not being displayed

    Dear GCB,
     
    HFTPTest - Copy.zip seems to be corrupt, please compress this package again and send it to eric@cutesoft.net
     
    Thank you for your business
    Eric@cutesoft.net 
  •  10-29-2010, 10:26 AM 64792 in reply to 64791

    Re: Images not being displayed

    Sent you the zip file. Thanks. 
  •  10-29-2010, 10:50 AM 64794 in reply to 64792

    Re: Images not being displayed

    Yeah, there is definitely a bug in the way you are handling GalleryClient changes. 
  •  10-29-2010, 12:14 PM 64801 in reply to 64794

    Re: Images not being displayed

    Dear GCB,
     
    I can reproduce this issue, you need change
     
    GalleryBrowser1.GalleryClient = "~/U_CuteSoft_Client/Gallery/";
    to
    GalleryBrowser1.GalleryClient = "U_CuteSoft_Client/Gallery/";
     
    After done, please try it again. I tried it on my end, when change this, it will work.
     
    Thank you for your business
  •  10-29-2010, 1:46 PM 64803 in reply to 64801

    Re: Images not being displayed

    Eric ,
     
    Yes, I already figured that out. Unfortunately, that fix does not work on my real website.  When I do that on it, it gives me a file not found exception:
     
    "Could not find a part of the path 'C:\\Users\\gary\\Documents\\Visual Studio 2010\\WebSites\\HFTPTest\\Pages\\Events\\HITEC\\U_CuteSoft_Client\\Gallery\\Layout\\SlideShow\\Template.htm'."}
     
    See how in this causes it build the wrong path when I don't include the "~/"?   Because the page with the DNG control is in the \\Pages\\Events\\HITEC\\  subdirectory
     
    It should be:
     
    'C:\\Users\\gary\\Documents\\Visual Studio 2010\\WebSites\\HFTPTest\\U_CuteSoft_Client\\Gallery\\Layout\\SlideShow\\Template.htm'
     
    Also, it seems strange that GalleryFolder would take a "~/" prefix and GalleryClient would not.  I don't know why you would design it that way, so I'm pretty sure you've got a bug here.  
     
    Fortunately, it does work when I don't rename the CuteSoft_Client directory at all.  This requires me to make a few changes here, but it's not too bad. But I would say again that I think you have a bug and I would hope you address it in future versions. 
     
     
    Thanks,  
    Gary  
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.