Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

ASP uploader not working in Firefox 3.6.3

Last post 08-02-2010, 8:34 PM by cutechat. 25 replies.
Page 1 of 2 (26 items)   1 2 Next >
Sort Posts: Previous Next
  •  06-09-2010, 3:44 AM 61638

    ASP uploader not working in Firefox 3.6.3

    Hi there,
     
    The ASP uploader does not work on both my local development machine as well as the servers where it is hosted. The button to select files is unresponsive, so no dialog appears.
     
    It still works in IE8 as well as Safari, and prior versions of Firefox.
     
    Please indicate how I can resolve this. (Urgent)
     
    Thanks
     
    Rob Nagel
  •  06-09-2010, 8:04 AM 61642 in reply to 61638

    Re: ASP uploader not working in Firefox 3.6.3

    Can you reproduce this issue in http://aspuploader.com/demo/form-singlefile.asp on your end?
    Can you post your ASP Uploader access url here or send it to eric@cutesoft.net? We will check it.
     
    Regards,
    Eric 
  •  06-09-2010, 4:57 PM 61648 in reply to 61642

    Re: ASP uploader not working in Firefox 3.6.3

    I'm having the same Issue but the example page "ajax-multiplefiles.asp" works fine in firefox but when I put the code into my custom ASP page it only worked in IE not firefox.
     
    Is there a know bug of some kind?
     
    Anyone find a solution?
  •  06-09-2010, 10:14 PM 61653 in reply to 61642

    Re: ASP uploader not working in Firefox 3.6.3

    Hi Eric,
     
    skfmn is right. The page fails in Firefox 3.6.3 when run from the VS2008 environment. I reproduced it on my machine by placing the code from simple-upload.aspx from the Framework2.0-VB folder. I added the line

    <%@ Register TagPrefix="CuteWebUI" Namespace="CuteWebUI" Assembly="CuteWebUI.AjaxUploader" %>

    and it fails as reported in FF 3.6.3 and runs in IE and Safari.
    I have also emailed you the page
     
    Thanks in advance for a fix
     
    Rob Nagel
     
  •  06-11-2010, 7:48 AM 61690 in reply to 61653

    Re: ASP uploader not working in Firefox 3.6.3

    Is there a solution to this problem yet, since I experience exactly the same symptoms as you described. (Upload button not clickable)
     
    Uploader works fine in IE, but not in FF anymore.
     
    The weirdest thing is that it behaves differently on different clients. 
    (5 clients: 3 not working, 2 works )
     
    Looking forward to a reply. 
     
    Picachuchu
  •  06-12-2010, 11:13 AM 61702 in reply to 61638

    Re: ASP uploader not working in Firefox 3.6.3

    Is ASP Uploader not supported any more?
     
    That would be a shame because I realy like this application!
     
    If I can't get this to work in FireFox my boss wants me to use something else. Does anyone know of another app. that does the same thing?
  •  06-13-2010, 3:53 PM 61706 in reply to 61690

    Re: ASP uploader not working in Firefox 3.6.3

    Hi Picachuchu,
     
    I have noticed in my environment that the Firefox bug is happening on Windows7 machines, and not on other O/S like XP. Is this the same for you as reported? Can you tell me the OS of the 5 clients you mentioned?
     
    Regards
     
    Rob Nagel
     
     
  •  06-14-2010, 5:20 AM 61724 in reply to 61706

    Re: ASP uploader not working in Firefox 3.6.3

    Hi Rob,
     
    all our server are Windows 7 with 2008 Webserver.
     
     The clients were a mixed, some Vista and some Windows 7.  It doesnt seem as if the OS makes any difference, since I it worked on some Vista maschines and on some it didnt. 
     
    I solved this problem after a huge amount of digging!
     
    It seems as if this control behaves this faulty exactly as described when you have the  Silverlight Plug-in 4.0.50524.0 activated in FF. I deactivated my plugin, reloaded the page and voila, the Upload button responded again!
     
    When I actived the  plugin the button again didnt work. So this is clearly the source of this problem.
     
    One issue I still didnt figure out though, is that I had all my FF plugins activated and the Upload button used to work. Im very sure of this because I was so surprised to see it suddenly not working and I knew I havent done anything out of place with FF or the application. 
    While working on my system I must have triggered something which caused this problem with the silverlight plugin. 
     
    If my observations are right this means, that you will have systems where the Uploader will work even though their Silverlight Plugin in FF is activated. 
     
    Have fun with the testing Rob!
     
    Picachuchu
  •  06-14-2010, 8:50 AM 61728 in reply to 61724

    Re: ASP uploader not working in Firefox 3.6.3

    Hi Picachuchu,
     
    I am glad this solved your issues. Unfortunately it does not solve mine. I do not have the Silverlight plug-in installed in FF as you describe.
     
    It is rather a concern to me, as CuteSoft does not seem able to reproduce the error, and I have many clients out there who potentially will.
     
    Is there anyone out there who could throw some light on the issue?
     
    Rob Nagel
  •  06-14-2010, 11:46 AM 61729 in reply to 61724

    Re: ASP uploader not working in Firefox 3.6.3

    Disabling the silverlight plug in did the trick for me, thanks Picachuchu!
     
    I have Vista Home Premium.
     
    I hope they come up with a fix for it as I dont want to have something on the page telling the users to disable the plugin and how to disable it.
  •  06-14-2010, 1:33 PM 61732 in reply to 61729

    Re: ASP uploader not working in Firefox 3.6.3

    OK, I found the Silverlight plug-in (not add-on as I thought) and once it was disabled diabled, FF3.6.3 works as expected.
     
    Thanks all who helped.
     
    Rob Nagel
  •  06-14-2010, 5:10 PM 61736 in reply to 61732

    Re: ASP uploader not working in Firefox 3.6.3

     I tested asp uploader in windows 7 and vista, it works both in flash and silverlight mode, Can you test it in http://aspuploader.com/demo/ajax-multiplefiles.asp?  Can you reproduce this issue?
     
    Regards,
    Eric
     
     
     
     
  •  06-16-2010, 9:38 AM 61809 in reply to 61736

    Re: ASP uploader not working in Firefox 3.6.3

    It works fine for me in your native script, but when I insert it into my ASP script it does not work with silverlight turned on.
     
    I commented out all my ASP code and Includes and it still didn't work with silverlight enabled...that is the strangest thing I have seen in a long while.
     
    I will look into it more and let you know what I find. 
  •  06-17-2010, 3:33 AM 61839 in reply to 61732

    Re: ASP uploader not working in Firefox 3.6.3

    Im glad I could help!
     
    We seriously need a fix for this please, because as mentioned before:
     
    << I hope they come up with a fix for it as I dont want to have something on the page telling the users to disable the plugin and how to disable it. >>
     
    This behaviour created huge issues for us  and we have to know whether it can be fixed or not, since if not we have to take other steps.
     
    CuteSoft should now have everything they need to look further into this. 
     
    Picachuchu
     
  •  06-25-2010, 3:48 PM 62008 in reply to 61839

    Re: ASP uploader not working in Firefox 3.6.3

    Hi all,
     
    It seems that Firefox has fixed the issue in version 3.6.4
     
    Download this version, and the ASP uploader will work in FF.
     
    Thank goodness for that.
     
    Rob Nagel
  •  06-29-2010, 1:04 PM 62078 in reply to 62008

    Re: ASP uploader not working in Firefox 3.6.3

    I upgraded to FF 3.6.4 today thinking it would resolve the issue, but it continues.
     
    I've tried disabling the Silverlight plug-in and that works, but my concern is that we have a fairly large and distributed user base where users may not even have access to disabling the plug-in. 
     
    Have CuteSoft found a fix for this?
  •  06-29-2010, 6:11 PM 62087 in reply to 62078

    Re: ASP uploader not working in Firefox 3.6.3

    I tested http://aspuploader.com/demo/ajax-multiplefiles.asp, it works in silverlight mode, the version of silverlight is v4.0.50524.0, os is win7. 
    Please test this online example, if issue is still existing, please tell us your os,browser version,silverlight version.
     
     
    Regards,
    Eric 
  •  07-08-2010, 5:00 PM 62370 in reply to 62087

    Re: ASP uploader not working in Firefox 3.6.3

    As stated before your demo works but when put in a real world application it fails.
     
    I'm am using Vista Home Premium, FireFox 3.6.6, Silverlight version 4.0.50524.0
     
    I cannot show you an example because it is in a secure directory that I can't give access to.
     
    I will see if I can make an example that you can have access to that duplicates the problem.
  •  07-12-2010, 3:12 PM 62437 in reply to 61839

    Re: ASP uploader not working in Firefox 3.6.3

    Ditto - we need a fix.  Our site is going live in a week or so (July 2010) and need this fixed.
     
    PLEASE!!!
Page 1 of 2 (26 items)   1 2 Next >
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.