Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

IE7 freezes after upload using IIS7

Last post 08-23-2009, 11:33 PM by Adam. 17 replies.
Sort Posts: Previous Next
  •  01-08-2009, 7:58 AM 47542

    IE7 freezes after upload using IIS7

    Trying to get AjaxUploader to work with IIS7 anf IE7, but after the files are uploader IE7 freezes.
    If i try from Mozilla firefox it works fine, i am using your sample code for Multiple file uploads, my config file is below, do you have any idea what the problem might be.
    I am using Windows integrated security and i have anonymous user disabled, so in firefox i get an authenticatioin window, while in IE7 works as expected however it freezes after an upload.
    Thanks 

    <?
    xml version="1.0"?>

    <configuration>

    <appSettings>

    <!-- You can set a low upload speed to test the progress bar. -->

    <!--

    <add key="CuteWebUI.AjaxUploader.UploadSpeedKB" value="20" />

    -->

    </appSettings>

    <system.web>

    <httpRuntime maxRequestLength="2000000"/>

    <pages>

    <controls>

    <add namespace="CuteWebUI" assembly="CuteWebUI.AjaxUploader" tagPrefix="CuteWebUI"/>

    <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

    </controls>

    <namespaces>

    <add namespace="System.Collections.Generic"/>

    <add namespace="System.IO"/>

    <add namespace="System.Data"/>

    <add namespace="System.Data.SqlClient"/>

    </namespaces>

    </pages>

    <compilation debug="true">

    <assemblies>

    <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

    <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    </assemblies>

    </compilation>

    <httpHandlers>

    <remove verb="*" path="*.asmx"/>

    <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

    <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

    <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>

    </httpHandlers>

     

    </system.web>

    <system.webServer>

    <modules>

    <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="managedHandler" />

    <!-- <add name="CuteWebUI.UploadModule" type="CuteWebUI.UploadModule,CuteWebUI.AjaxUploader" preCondition="managedHandler" /> -->

    <add name="CuteWebUI.UploadModule" type="CuteWebUI.UploadModule,CuteWebUI.AjaxUploader"/>

     

    </modules>

    <handlers>

    <add name="ScriptResource.axd_GET,HEAD" path="ScriptResource.axd" verb="GET,HEAD" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv2.0" />

    <add name="*_AppService.axd_*" path="*_AppService.axd" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv2.0" />

    <add name="*.asmx_*" path="*.asmx" verb="*" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv2.0" />

    </handlers>

    <validation validateIntegratedModeConfiguration="false" />

    </system.webServer>

    </configuration>

  •  01-08-2009, 8:39 AM 47544 in reply to 47542

    Re: IE7 freezes after upload using IIS7

    Hi,
     
    I can't reproduce your issue.
     
    Can you test each mode of the Uploader.UploadType ?
     
    Regards,
    Terry
  •  01-08-2009, 9:13 AM 47545 in reply to 47544

    Re: IE7 freezes after upload using IIS7

    Uploader.UploadType ="Flash"-->authentication box pop up and then it freezes
    Uploader.UploadType ="Auto"--> browser freesez after upload is complete
    Uploader.UploadType ="SilverLight"--> works fine no problems there, no authentication box appears and no browser freezes up
    Uploader.UploadType="Iframe"--> works fine but only one file can be selected
     
    Thanks
  •  01-08-2009, 9:42 AM 47546 in reply to 47545

    Re: IE7 freezes after upload using IIS7

    wassimsa,
    It seems that Flash do not works well for your condition. you can disable the flash mode temporary by this way,
     
    uploader.SetAdvancedOption(UploaderAdvancedOption.NoFlash, "true");
     
    If we can reproduce it , we will improve it.
     
    Regards,
    Terry
  •  01-08-2009, 9:56 AM 47551 in reply to 47546

    Re: IE7 freezes after upload using IIS7

    by the way ,
     
    I think you are using Flash8,9 ,
     
    Please try Flash10.
     
    If you can control the PCs of your end users,
     
    I suggest you let them all install silverlight and disable the flash mode.
     
    Regards,
    Terry
     
     
  •  01-08-2009, 10:10 AM 47553 in reply to 47551

    Re: IE7 freezes after upload using IIS7

    actually its flash 10 that is installed.
    users will definetly have flash installed but not silverlight as the flash is instyalled with the operating system image, i saw on the forums that flash should be able to work with integrated security without asking for authentication, why isn't it working in my case?
    Thanks
  •  01-08-2009, 10:34 AM 47556 in reply to 47553

    Re: IE7 freezes after upload using IIS7

    Hi,
     
    I don't know why. Because I can't reproduce the problem. All works on our test environment.
     
    Can you tell me how you configure the IIS7 ?
     
    Regards,
    Terry
  •  01-08-2009, 11:00 AM 47558 in reply to 47556

    Re: IE7 freezes after upload using IIS7

    all authentication modes are disabled except for windows integrated security.
    I am getting the same error,http,401
    that is on this thread
    Thanks
  •  01-08-2009, 1:03 PM 47565 in reply to 47558

    Re: IE7 freezes after upload using IIS7

    Hi,
     
    Now I can reproduce it now.
     
    the Flash do not support Integrated Windows Authentication .
     
    But I have a new way to pass the Flash upload request to another page.
     
    We still need time to do more tests, and would provide an update next week.
     
    Regards,
    Terry
  •  01-08-2009, 1:08 PM 47566 in reply to 47565

    Re: IE7 freezes after upload using IIS7

    thanks
  •  01-08-2009, 11:14 PM 47575 in reply to 47566

    Re: IE7 freezes after upload using IIS7

    Hi,
     
    We have fixed this issue for Firefox.
     
    But the IE would cut all flash uploading data while IE think it need authentication handshake.
     
    We will continue on this issue and provide a solution next week.
     
     
    Regards,
    Terry
  •  01-15-2009, 7:14 AM 47766 in reply to 47575

    Re: IE7 freezes after upload using IIS7

    Just wondering if there is any progress on the above issue
    thanks
  •  01-15-2009, 9:51 AM 47781 in reply to 47766

    Re: IE7 freezes after upload using IIS7

    Hi,
     
    We are still investigating on this issue.
     
    Regards,
    Terry
  •  01-26-2009, 7:31 AM 48052 in reply to 47781

    Re: IE7 freezes after upload using IIS7

    Hello, As we wait for a fix for this issue, would it be faster to hacve a fix for the cancel silverlight scenario posted on this thread?
     
    We need to have a reliable solution for multi file upload using integrated security.
    and IE7
     
     
    Thanks
  •  01-27-2009, 9:53 AM 48094 in reply to 48052

    Re: IE7 freezes after upload using IIS7

    Hi,
     
    We are working very deep on windows auth algorithm , and it would need some days.
     
    We will publish a new patch in 3 days temporary, include that silverlight cancel issue, without windows auth issue.
     
    Regards,
    Terry
     
  •  01-28-2009, 8:40 AM 48139 in reply to 48094

    Re: IE7 freezes after upload using IIS7

    thanks
  •  02-03-2009, 1:08 PM 48312 in reply to 48139

    Re: IE7 freezes after upload using IIS7

    Hi,
     
    Please download the control and try again.
     
    We just release an update. please check this thread:
     
     
    Regards,
    Terry
  •  08-23-2009, 11:33 PM 54931 in reply to 48312

    Re: IE7 freezes after upload using IIS7

    Guys,
     
    In the latest build we have a better solution to resolve this issue.
     
    With this new solution, you don't need to configure the FlashUploadPage.
     
    Please download the control and try again.
     
    Keep me posted

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.