Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Safari problem with editor without content

Last post 06-28-2006, 3:30 AM by Sajjan. 23 replies.
Page 2 of 2 (24 items)   < Previous 1 2
Sort Posts: Previous Next
  •  06-16-2006, 3:08 PM 20226 in reply to 19923

    Re: Safari problem with editor without content

    The thing is Adam, this issue is real intermittent.  You example works fine - however in my application it's intermittent.  I do see a message in the Safari status bar that says "Cancelled opening the page" on pages that do not display the content in the editors (I sometimes have 3, 4, or 5 editors on the same page).  I've been trying to create a simple test app that demonstrates the issue but am unable to do so - I'll keep working on it though.
     
    Ted
  •  06-16-2006, 4:29 PM 20227 in reply to 19923

    Re: Safari problem with editor without content

    Adam,
     
    I figured out the problem.  I have the editors hidden (table row with display style set to 'none') and when I do this, your editor will not populate the text into the textarea field.  When I change the display style to 'inline' the content appears as it should.   Here is a sample page for testing purposes.  Safari doesn't like the way I'm doing the show/hide so I'm going to look into a different way of doing this, however I'm not sure if the editor can handle populating the a hidden textarea.
     
    Regards,
    Ted
     
     
     
    <%@ Page Language="c#" %>
    <%@ Import NameSpace="System"%>
    <%@ Register TagPrefix="CE" Namespace="CuteEditor" Assembly="CuteEditor" %>
    <script language="C#" runat="server">
     public void Page_Load(Object Source, EventArgs E)
     {
      Editor1.Text = "Editor 1 Text";
     }
    </script>
    <html>
     <body>
     <form id="EditorTest" runat="server">
      <table cellpadding="5" cellspacing="0" border="0">
       <tr><td>&nbsp;<a class="clsRequiredField" href="#" onclick="BLOCKED SCRIPTif(this.parentElement.parentElement.nextSibling.style.display=='none') this.parentElement.parentElement.nextSibling.style.display='inline';else this.parentElement.parentElement.nextSibling.style.display='none';return(false);" ><font style="font-size:10px; color:Maroon;">(click here to show/hide)</font></a></td></tr>
       <tr style="DISPLAY:none;">
        <td valign="middle" style="border: 1px solid #CCCCCC">
         <CE:Editor id="Editor1" Width="350" runat="server" Height="200" ThemeType="OfficeXP" EnableContextMenu="False" AutoConfigure="Minimal" /><br /><br />
        </td>
       </tr>
      </table>
     </form>
     </body>
    </html>
  •  06-28-2006, 12:51 AM 20542 in reply to 19723

    Re: Safari problem with editor without content

    Hello Adam,
    I am working on CuteEdotor 5.3 with ASP.NET 2.0. I have similar problems with Safari browser 2.0 with MacOs 10x. I still could not get my answers yet. Can you please help me on how to get CuteEditor 5.3 working on Safari 2.0. Your early action shall be highly appreciated.
     
    Best Regards
     

    Sajjan Kumar,
    Senior Developer,
    V-Access India Pvt. Ltd.
    428, Udyog Vihar, Gurgaon 122001
    India
  •  06-28-2006, 3:30 AM 20543 in reply to 20000

    Re: Safari problem with editor without content

    Hi Justin,
    Can you help me out? I need to know the trick so that Cute Editor 5.3 can work on Safari Browser 2 with MacOS 10x using ASP.NET 2.0
     
    Thanks in Advance,
     

    Sajjan Kumar,
    Senior Developer,
    V-Access India Pvt. Ltd.
    428, Udyog Vihar, Gurgaon 122001
    India
Page 2 of 2 (24 items)   < Previous 1 2
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.