Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

'System.Web.Extensions' is invalid

Last post 05-23-2014, 9:00 AM by Kenneth. 1 replies.
Sort Posts: Previous Next
  •  05-22-2014, 10:16 AM 80314

    'System.Web.Extensions' is invalid

    Our primary server recently when down and we switched to the back up.  Now we are getting an error in the web.config file and cannot begin to figure out what could be different that is causing the new error.  Can you please give me some guidance on where to start looking?  (Note: I'm not a .net nor server admin so be gentle with me.)

    Thanks!

    Cindy 

     

    web.config:

    <?xml version="1.0"?>
    <configuration>
      <appSettings>

       <add key="AjaxUploaderLicense" value="~/ajaxuploader.lic" />

      </appSettings>
      <system.web>
            <customErrors mode="Off"/>
        </system.web>

      <system.web>
        <httpRuntime maxRequestLength="2000000"/>
      
        <pages>
          <controls>
            <add namespace="CuteWebUI" assembly="CuteWebUI.AjaxUploader" tagPrefix="CuteWebUI"/>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          </controls>
          <namespaces>
            <add namespace="System.Collections.Generic"/>
            <add namespace="System.IO"/>
            <add namespace="System.Data"/>
            <add namespace="System.Data.SqlClient"/>
          </namespaces>
        </pages>
        <compilation debug="true">
          <assemblies>
            <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
            <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
          </assemblies>
        </compilation>
        <httpHandlers>
          <remove verb="*" path="*.asmx"/>
          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
        </httpHandlers>
        <httpModules>
          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
          <add name="CuteWebUI.UploadModule" type="CuteWebUI.UploadModule,CuteWebUI.AjaxUploader"/>
        </httpModules>
      </system.web>
    </configuration> 

     

    Error Msg:

    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

    Parser Error Message: The format of the file 'System.Web.Extensions' is invalid.

    Source Error: 


    Line 42:     </httpHandlers>
    Line 43:     <httpModules>
    Line 44:       <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    Line 45:       <add name="CuteWebUI.UploadModule" type="CuteWebUI.UploadModule,CuteWebUI.AjaxUploader"/>
    Line 46:     </httpModules>
     

    Source File: c:\inetpub\wwwroot\web.config    Line: 44

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'System.Web.Extensions' could not be loaded.


    === Pre-bind state information ===
    LOG: DisplayName = System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
     (Fully-specified)
    LOG: Appbase = file:///c:/inetpub/wwwroot
    LOG: Initial PrivatePath = bin
    Calling assembly : (Unknown).
    ===

    LOG: Publisher policy file is not found.
    LOG: No redirect found in host configuration file (C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet.config).
    LOG: Using machine configuration file from C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\config\machine.config.
    LOG: Post-policy reference: System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
    LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/2135a508/8d69a834/System.Web.Extensions.DLL.
    LOG: Attempting download of new URL file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET Files/root/2135a508/8d69a834/System.Web.Extensions/System.Web.Extensions.DLL.
    LOG: Attempting download of new URL file:///c:/inetpub/wwwroot/bin/System.Web.Extensions.DLL.

     


    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:1.1.4322.2504; ASP.NET Version:1.1.4322.2505  

  •  05-23-2014, 9:00 AM 80315 in reply to 80314

    Re: 'System.Web.Extensions' is invalid

    Hi cjchamber,

     

    Please check your site application pool, you are using the .net framework 1.1, ajax uploader must use .net framework 2.0+.

     

    By the way, this error is not causes by the uploader, it is causes by your web.config setting, .net framework 1.1 does not support System.Web.Extensions control, and you are using it in web.config, this is why causes this problem.

     

    Regards,

     

    Ken 

View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.