Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Unicode characters in RTF output

Last post 11-29-2010, 11:46 AM by cbeuker. 9 replies.
Sort Posts: Previous Next
  •  11-18-2010, 3:00 PM 65079

    Unicode characters in RTF output

       Greetings.
     
    I have noticed that if I paste some text with a unicode character in it  ( “ for example ), it will put the proper code character in the HTML, however, if you save that to RTF (using the SaveRTF method), it will put the text “ in the RTF.  When you open the RTF in word or something, it will then display “ in the text of the document as opposed to the quote it represents.
     
    Am I missing some setting on the control so this will save properly?  Or is there nothing one can do about this.
     
    Thanks in advance..
     
    cmb..
  •  11-18-2010, 7:34 PM 65080 in reply to 65079

    Re: Unicode characters in RTF output

    Hi cbeuker,
     
    Can you reproduce this issue on demo http://www.cutesoft.net/example/editRTF.aspx ?
     
    If so, please so me the steps to reproduce it. I will check it and get back to you as soon as possible.
     
    Regards,
     
    ken
  •  11-19-2010, 10:49 AM 65098 in reply to 65080

    Re: Unicode characters in RTF output

    Hi there,
     
    I pasted the following text into the textbox on the demo page
     
    THAT “the Working Interest Owners approve of the change to subclause 102. of Appendix IV of Exhibit “A” to
    I hit submit.  The textbox below the submit button shows what the HTML is.
     
    Now, it is my understanding that if I click the    "Check the RTF File" link, I will get the RTF of the above string.
    All I got was something that in no way resembled what I entered.
     
    If you have other questions, let me know..
     
  •  11-19-2010, 10:51 AM 65099 in reply to 65098

    Re: Unicode characters in RTF output

    Oh, one other thing, also, when I used the SavePDF function, it also rendered the unicode string as opposed to the actual character.
     
    Separate (but probably related) issue, but I figured I would mention it as well.
  •  11-19-2010, 12:31 PM 65102 in reply to 65099

    Re: Unicode characters in RTF output

    Tried using the demo editor again and was able to re-create the problem online.
     
    Basically, if you go into the html editor on the demo page and plaster the following in the editor
     
    Invalid Character 1: “
    Invalid Character 2: ”
    Invalid Character 3: ’
    It will render the correct character in the browser, but not on RTF or PDF.
     
    This probably goes for other unicode characters  as well.
     
    cmb..
  •  11-21-2010, 7:45 PM 65108 in reply to 65102

    Re: Unicode characters in RTF output

    Hi cbeuker,
     
    I can reproduce this issue. We investigating this issue and will get back to you as soon as possible.
     
    Regards,
     
    ken
  •  11-24-2010, 7:11 PM 65154 in reply to 65108

    Re: Unicode characters in RTF output

    Cool, let me know what comes of it..
  •  11-24-2010, 9:20 PM 65157 in reply to 65154

    Re: Unicode characters in RTF output

    Hi cbeuker,
     
    We have fixed this issue. We will update the new version soon.
     
    Regards,
     
    Ken
  •  11-28-2010, 7:42 PM 65179 in reply to 65154

    Re: Unicode characters in RTF output

    Hi cbeuker,

    This issue has been fixed, please download the latest version and try again.

    Latest version download http://www.cutesoft.net/downloads/folders/21904/download.aspx

    Regards,

    Ken
  •  11-29-2010, 11:46 AM 65199 in reply to 65179

    Re: Unicode characters in RTF output

    Just got the bits.  All looks good so far.  We will continue to test here.
     
    Thanks.
     
    cmb..
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.