Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

<br/ /> in output causing xhtml to not validate

Last post 11-16-2010, 1:08 AM by cutechat. 10 replies.
Sort Posts: Previous Next
  •  01-10-2009, 7:16 PM 47625

    <br/ /> in output causing xhtml to not validate

    Any idea why its writing <br/> like <br/ /> ?
     
    Is this by design? 
     
    I am using:
    CuteEditor for Classic ASP v6
     
    Here is a sample output:
    ================
    <div>This</div>
    <div>is</div>
    <div>a test<br/ />
    </div>
    ================
    I simply wrote each line and hit enter.

     
    My Form code is:
    =================
          <%
                Dim editor
                Set editor = New CuteEditor
                with editor
                    .ID = "scabio"
                    .Text = vSCABio
                    .XHTMLOutput = true
                    .ShowHtmlMode = false
                    .width="575"
                    .FilesPath = "CuteEditor_Files"
                    .ConfigurationPath = "/CuteEditor_Files/Configuration/myTools.config"
                    .ImageGalleryPath = "/memberpics"
                    .EditorBodyStyle = "font:normal 12px arial;"
                    .EditorWysiwygModeCss = "asp.css"
                    .Draw()
                end with
            %>
  •  01-10-2009, 8:04 PM 47626 in reply to 47625

    Re: <br/ /> in output causing xhtml to not validate

    This is a bug. We just fixed it.
     
    Please try following example:
     
     
    If it works for you, please download the control again.

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  01-13-2009, 1:34 PM 47700 in reply to 47626

    Re: <br/ /> in output causing xhtml to not validate

    Thanks for the prompt action. 
     
    btw: I am sure that I reviewed cute editor years ago, its come a long way since then great work!
  •  01-13-2009, 1:56 PM 47701 in reply to 47700

    Re: <br/ /> in output causing xhtml to not validate

    Thanks I got the new version and my output now validates as XHTML.
     
    Fantastic!
  •  09-14-2010, 11:02 PM 64017 in reply to 47701

    Re: <br/ /> in output causing xhtml to not validate

    Something has gone amiss.  My editor is adding this malformed break again as <br//>
     
    How can I check which version I am using?
  •  09-15-2010, 8:48 AM 64026 in reply to 64017

    Re: <br/ /> in output causing xhtml to not validate

    Dear lonecrow,
     
    Can you reproduce this issue in http://cutesoft.net/asp/oncarriagereturn.asp?BreakElement=br ? I tested it, it is <br />.  If it works for you, please download the control again. Download url: http://cutesoft.net/downloads/folders/asp-editor/entry57121.aspx
     
    Thank you for asking
     
  •  11-11-2010, 2:03 AM 64969 in reply to 64026

    Re: <br/ /> in output causing xhtml to not validate

    Hi,
     
    we have the same problem. I downloaded the file, but is does not fix the problem ?
     
     
  •  11-11-2010, 3:34 AM 64970 in reply to 64969

    Re: <br/ /> in output causing xhtml to not validate

    Hi Jorbo,
     
     
    Is your site online? If so, can you send me the test page url and show me the steps to reproduce this issue? So I can check it for you.
     
    Regards,
     
    Ken 
  •  11-11-2010, 4:09 AM 64971 in reply to 64970

    Re: <br/ /> in output causing xhtml to not validate

    Ken,
     
    on your demo is works. 
     
    We use editor.XHTMLOutput=true 
    If we disable this feature it works fine.
     
    Bug ?
     
    Regards,
     
    Joram 
  •  11-14-2010, 7:53 PM 64999 in reply to 64971

    Re: <br/ /> in output causing xhtml to not validate

    Hi jorbo,
     
    We will fix this issue soon.
     
    For now, you can add the code below into the page and try again.
     
    <script>
    function CuteEditor_FilterHTML(editor,code)
    {
     return code.split("<br/ />").join("<br/>");
    }
    function CuteEditor_FilterCode(editor,code)
    {
     return code.split("<br/ />").join("<br/>");
    }
    </script>
     
    Regards,
     
    ken
  •  11-16-2010, 1:08 AM 65021 in reply to 47625

    Re: <br/ /> in output causing xhtml to not validate

    Hi,
     
    We have fixed it , and will provide update soon.
     
    You can also modify the Constant.js to fix it temporary.
     
    change the
     
    editorconstant.UseXhtmlFormat=true;
     
    to
     
    editorconstant.UseXhtmlFormat=false;
     
    Regards,
    Terry
     
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.