Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Ox6[OxO72c7[26]].setAttribute is not a function

Last post 03-04-2010, 3:52 PM by Adam. 4 replies.
Sort Posts: Previous Next
  •  02-26-2010, 12:47 PM 59021

    Ox6[OxO72c7[26]].setAttribute is not a function

    I'm pretty new to using this control, but we've been very pleased with it.  However, I just took on the project of moving my project to VS 2008 and updating to .Net 3.5.  I've gotten all my kinks worked out now except for one.  I have a page that hasn't changed from the old version, but now that it's in .Net 3.5, I get the error "Ox6[OxO72c7[26]].setAttribute is not a function" from the AjaxUploader control.  The same code in the old product has no issues.  Can anyone help?
     
    Thanks. 
  •  02-28-2010, 9:01 AM 59041 in reply to 59021

    Re: Ox6[OxO72c7[26]].setAttribute is not a function

    Hi,
     
    Please try the last version.
     
    I think you are using a old version because the object name is Ox6 .
     
    Regards,
    Terry
  •  03-01-2010, 11:31 AM 59061 in reply to 59041

    Re: Ox7[OxO3669[28]].setAttribute is not a function

    Thank you for the suggestion, however after downloading the newest dll, I still get the error, just a different name for the control.
     
    Ox7[OxO3669[28]].setAttribute is not a function 
  •  03-04-2010, 11:56 AM 59177 in reply to 59061

    Re: Ox7[OxO3669[28]].setAttribute is not a function

    For anyone else who encounters this, I found the issue.  It actually was the AjaxControlToolkit.  Apparently, the newest release does not dispose of controls properly when you have a modalpopupextender inside of an update panel.  As a result, multiple controls of the same ID get created on the page.  This caused me a whole lot of pain.  This error turned out to be only the tip of the ice burg.  Once I rolled back to an earlier version of the toolkit, all my problems went away.
     
    Thanks. 
  •  03-04-2010, 3:52 PM 59182 in reply to 59177

    Re: Ox7[OxO3669[28]].setAttribute is not a function

    drudo:
    For anyone else who encounters this, I found the issue.  It actually was the AjaxControlToolkit.  Apparently, the newest release does not dispose of controls properly when you have a modalpopupextender inside of an update panel.  As a result, multiple controls of the same ID get created on the page.  This caused me a whole lot of pain.  This error turned out to be only the tip of the ice burg.  Once I rolled back to an earlier version of the toolkit, all my problems went away.
     
    Thanks. 
     
    Glad to know you figured out this issue.

    Thanks for the tip.

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.