Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

You are probably hitting the file upload limit of IIS7.By default in IIS 7 requestFiltering has the MaxAllowedContentLength property enabled.It specifies, in bytes, the maximum length of the content in a request. The default is 30MB.

Last post 08-02-2009, 8:05 PM by cutechat. 4 replies.
Sort Posts: Previous Next
  •  07-29-2009, 6:51 AM 54362

    You are probably hitting the file upload limit of IIS7.By default in IIS 7 requestFiltering has the MaxAllowedContentLength property enabled.It specifies, in bytes, the maximum length of the content in a request. The default is 30MB.

    The control works fine on my Pc with Xamp under Windows, but do not work on Linux - Apache
    At the end of the upload process ("green bar full") I have this error


    You are probably hitting the file upload limit of IIS7.By default in IIS 7 requestFiltering  has the MaxAllowedContentLength property enabled.It specifies, in bytes, the maximum length of the content in a request. The default is 30MB.
     
    I have cheched my php.ini and it seems all the requirements are met
    Also I had to modify the include.php because the original version fails to retrieve the web path ( maybe because I have a symbolic link )
     
    I have try to modify the form-single.php in this way
     
     $uploader->TempDirectory="/var/www/apache2-default/prod/sl/vzilla/test1";
                            $uploader->MaxSizeKB=102400;
                            $uploader->MultipleFilesUpload=false;
                            $uploader->Name="myuploader";
                            $uploader->InsertText="Upload File (Max 100M)";
                            echo $uploader->TempDirectory;

    but nothing changes. Finally, I made a php that writes a file into this directory, /var/www/apache2-default/prod/sl/vzilla/test1, and it works
     
    Could you help, please ?
     
  •  07-29-2009, 10:14 AM 54368 in reply to 54362

    Re: You are probably hitting the file upload limit of IIS7.By default in IIS 7 requestFiltering has the MaxAllowedContentLength property enabled.It specifies, in bytes, the maximum length of the content in a request. The default is 30MB.

    It looks like you are using IIS.
     
    IIS7 and large files

    By default in IIS 7 requestFiltering  has the MaxAllowedContentLength property enabled. It specifies, in bytes, the maximum length of the content in a request. The default is 30,000,000 (approximately 30 megabytes.) To change this value you must edit the following file:

    %windir%\System32\inetsrv\config\applicationHost.config.

    In the ApplicationHost.config file, locate the <requestLimits> node.

    Modify the following code.

    <requestLimits maxAllowedContentLength ="10000000" />

    This is a definitely server settting issue.

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  07-30-2009, 12:22 AM 54388 in reply to 54362

    Re: You are probably hitting the file upload limit of IIS7.By default in IIS 7 requestFiltering has the MaxAllowedContentLength property enabled.It specifies, in bytes, the maximum length of the content in a request. The default is 30MB.

    Hi,
     
    That error message caused by 404 error.
     
    I think the uploader do not calcualte the path correctly on your server.
     
    Can you post the HTML code the uploader rendered?
     
    Regards,
    Terry
     
  •  07-30-2009, 5:16 AM 54404 in reply to 54388

    Re: You are probably hitting the file upload limit of IIS7.By default in IIS 7 requestFiltering has the MaxAllowedContentLength property enabled.It specifies, in bytes, the maximum length of the content in a request. The default is 30MB.

    This is the HTML code, please note that now with Mozilla Firefox works fine, the problem is with Google Chrome
     
     
    ---------------
     
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <title>
            Allegati richieste
        </title>
        <link href="demo.css" rel="stylesheet" type="text/css"  ></head>
    <body>
        <div class="demo">
                            
            <!-- do not need enctype="multipart/form-data" -->
            <form id="form1" method="POST">
                <fieldset><legend>Richiesta</legend><table><tr><td class=fld>Req#</td><td class=val>18351</td></tr><tr><td class=fld>Priorità</td>    <td class=val>Urgente</td>  </tr>  <tr>    <td class=fld>Categoria</td>    <td class=val>      Richiesta intervento/Ced    </td>  </tr>  <tr>    <td class=fld>Aperta da</td>    <td class=val>Fabrizio Vola</td>  </tr>  <tr>    <td class=fld>Utente di destinazione</td>    <td class=val>Enzo Ippolito</td>  </tr></table></fieldset><button id='myuploaderButton' onclick='return false;'>Selezionare l'allegato</button><input type='hidden' id='myuploader' name='myuploader' autocomplete='off' /><script type='text/javascript' src='phpuploader/ajaxuploaderresource.php?type=script'></script><img id='AjaxUploaderFiles_Loader' UniqueID='myuploader'  Namespace='CuteWebUI' UploadModuleNotInstall='1' src='phpuploader/ajaxuploaderresource.php?type=file&amp;file=continuous.gif' InsertButtonID='myuploaderButton' ResourceHandler='phpuploader/ajaxuploaderresource.php' UploadUrl='phpuploader/ajaxuploaderhandler.php' MaxSizeKB='1024000' CancelUploadMsg='Cancel upload' CancelAllMsg='Cancel all Uploads' UploadingMsg='Uploading..' UploadType='Auto' ShowProgressBar='1' ShowProgressInfo='1' NumFilesShowCancelAll='2' PanelWidth='360' BarHeight='20' InfoStyle='padding-left:3px;font:normal 12px Tahoma;' BarStyle='Continuous' BorderStyle='border:1px solid #444444;' onload='this.style.display=&quot;none&quot; ; CuteWebUI_AjaxUploader_Initialize(this.id);' onerror='this.onload()' ContextValue='TODO' />        </form>
            
            <br/><br/>
                
                            
        </div>
    </body>
    </html>
  •  08-02-2009, 8:05 PM 54442 in reply to 54404

    Re: You are probably hitting the file upload limit of IIS7.By default in IIS 7 requestFiltering has the MaxAllowedContentLength property enabled.It specifies, in bytes, the maximum length of the content in a request. The default is 30MB.

    Hi,
     
    Can you reproduce the same error on our online demo site ? http://phpfileuploader.com/demo/form-keepingstate.php
     
    please make sure the Chrome do not get 404 error on your page : http://yourapp.com/phpuploader/ajaxuploaderhandler.php
     
     
    Regards,
    Terry
View as RSS news feed in XML
Powered by Community Server (Commercial Edition), by Telligent Systems