Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Error upon installation of Cute Live Support

Last post 03-01-2012, 9:08 AM by cliu. 14 replies.
Sort Posts: Previous Next
  •  04-20-2011, 12:21 AM 67256

    Error upon installation of Cute Live Support

    Upon the installation of cute live support
     
    When i run the operator and try to connect, an error occured during the opening of form:
     
    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.InvalidCastException: Unable to cast COM object of type 'System.__ComObject' to interface type 'mshtml.DispHTMLStyle'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{3050F55A-98B5-11CF-BB82-00AA00BDCE0B}' failed due to the following error: No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).
       at LiveSupport.HtmlControl.UpdateDocUI()
       at LiveSupport.HtmlControl.LoadAboutBlank(String contenthtml)
       at LiveSupport.HtmlControl.LoadAboutBlank()
       at LiveSupport.Controls.MyCustomerList.MyCustomerList_Load(Object sender, EventArgs e)
       at System.Windows.Forms.UserControl.OnLoad(EventArgs e)
       at System.Windows.Forms.UserControl.OnCreateControl()
       at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
       at System.Windows.Forms.Control.CreateControl()
       at System.Windows.Forms.Control.ControlCollection.Add(Control value)
       at LiveSupport.MainLayout.AddInto(Control panel, Control child, String title, Icon boxicon)
       at LiveSupport.MainLayout.LoadControls()
       at LiveSupport.AsyncManager.RunInternal(Boolean processNewQueue, TimeSpan timeout)
       at LiveSupport.Program.ProcessAsyncQueue(Boolean processNewQueue)
       at LiveSupport.Program.timer_Tick(Object sender, EventArgs e)
       at System.Windows.Forms.Timer.OnTick(EventArgs e)
       at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4211 (VistaSP2GDR.050727-4200)
        CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    ----------------------------------------
    LiveSupport
        Assembly Version: 5.1.0.0
        Win32 Version: 5.1.0.0
        CodeBase: file:///C:/LiveSupportOperator/LiveSupport.exe
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4205 (VistaSP2GDR.050727-4200)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Configuration
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    ----------------------------------------
    System.Xml
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------
    System.Web.Services
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Web.Services/2.0.0.0__b03f5f7f11d50a3a/System.Web.Services.dll
    ----------------------------------------
    ubpe5htn
        Assembly Version: 5.1.0.0
        Win32 Version: 2.0.50727.4205 (VistaSP2GDR.050727-4200)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    Microsoft.mshtml
        Assembly Version: 7.0.3300.0
        Win32 Version: 7.0.3300.0
        CodeBase: file:///C:/Windows/assembly/GAC/Microsoft.mshtml/7.0.3300.0__b03f5f7f11d50a3a/Microsoft.mshtml.dll
    ----------------------------------------
    System.Web
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.4209 (VistaSP2GDR.050727-4200)
        CodeBase: file:///C:/Windows/assembly/GAC_32/System.Web/2.0.0.0__b03f5f7f11d50a3a/System.Web.dll
    ----------------------------------------
    XPCommonControls
        Assembly Version: 3.0.2.902
        Win32 Version: 3.0.2.902
        CodeBase: file:///C:/LiveSupportOperator/XPCommonControls.DLL
    ----------------------------------------
    Microsoft.VisualBasic
        Assembly Version: 8.0.0.0
        Win32 Version: 8.0.50727.4016 (NetFxQFE.050727-4000)
        CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    ----------------------------------------

    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.

     
    Hope for your immediate response..
     
    Currently working on .net framework 4.0.
    Windows Vista. Microsoft SQL Server 2008 r2
    Hope for your immediate response, badly needed.
     
     
     
     
     
  •  04-20-2011, 7:59 AM 67261 in reply to 67256

    Re: Error upon installation of Cute Live Support

    Dear finalcustomer,
     
    When do you have this issue? Has it ever worked fine?
    Please follow steps:
    1. Please backup snippets.xml,images.xml,and urls.xml
    2. Please uninstall operator client
    3. Download Http://cutesoft.net/download/LiveSupportOperatorClient.msi  and reinstall the operator client
    4. Try it again.
     
    Keep us posted.
     
    Thank you for asking
  •  04-25-2011, 4:02 AM 67311 in reply to 67261

    Re: Error upon installation of Cute Live Support

    Hello Eric,
     
       I've encountered this issue the time when I posted here in the forum.. Yes it worked fine before.. I dont know why this error appear. :(
    After I back up those three files you have mentioned, uninstall live support client, and again install, what will I do with those files that I've back-up?
     
    Thanks for the response.
  •  04-25-2011, 8:34 AM 67314 in reply to 67311

    Re: Error upon installation of Cute Live Support

    Dear finalcustomer,
     
    Those 3 files store "Canned Images","Canned Messages", and "Canned URLS". If you have never set Canned materials, you can ignore this step. If you have set them, please copy those 3 files to the new installation of operator client, it will override original files.
     
    Thank you for asking
  •  04-25-2011, 8:05 PM 67323 in reply to 67314

    Re: Error upon installation of Cute Live Support

    I've tried to reinstall the application, that error doesnt came along. But another problem is that when I tried to accept a chat session and click accept, nothing happens, even if i click the button "Accept", the window still remains and the status of the client is still waiting. What will i do?
  •  04-25-2011, 8:07 PM 67324 in reply to 67323

    Re: Error upon installation of Cute Live Support

    When the operator is available, the button turns to online, well that's correct. But when I tried to accept a chat session or invite the particular customer, it doesnt reflect or nothing happens. Please help. Thanks.
  •  04-26-2011, 4:32 AM 67328 in reply to 67324

    Re: Error upon installation of Cute Live Support

    Another question, what are the things that are needed to adjust in Cute Live Support once I converted to .net framework 4.0?.. Hope for response with my reply.
  •  04-26-2011, 7:24 AM 67332 in reply to 67324

    Re: Error upon installation of Cute Live Support

    Dear finalcustomer,
     
    You are using the server side of old version, it leads to this issue, please upgrade the code of server side to latest version and try it again.
     
    Hope it helps.
    Keep me posted.
     
    Thank you for asking
  •  04-26-2011, 6:53 PM 67333 in reply to 67332

    Re: Error upon installation of Cute Live Support

    Hello,
     
    How will I upgrade the code of my server side?
  •  04-26-2011, 8:35 PM 67337 in reply to 67333

    Re: Error upon installation of Cute Live Support

    Hi finalcustomer,
     
    1. Download the package http://www.cutesoft.net/downloads/folders/21855/download.aspx
     
    2. Delete file "LiveSupportWeb.dll", "CuteChat.dll" and  "CuteChat.AppCode.dll". (before this step, please backup the files)
     
    3. Delete folder "CuteSoft_Client". Please do not replace, just delete it. (before this step, please backup the files)
     
    4. Re-deploy the files/folder above.
     
    Regards,
     
    Ken
  •  02-28-2012, 2:00 PM 73245 in reply to 67337

    Re: Error upon installation of Cute Live Support

    Ken,
     
    I got the same error as posted. After reinstalled the client as instructed, the error message disappeared, but the customer could not see the message I sent. Then I applied the above mentioned solution on the server end, the "On Line Support" icon for customers disappeared from our website. Please help to fix it..
     
    Finalcustomer,
     
    Did you try it and did it work for you?
     
    Thanks,
     
    Cindy
  •  02-28-2012, 2:40 PM 73246 in reply to 73245

    Re: Error upon installation of Cute Live Support

    Hi cliu,
     
    Can you show me your support site url? I will check it and get back to you as soon as possible.
     
    Regards,
     
    Ken 
  •  02-28-2012, 3:58 PM 73247 in reply to 73246

    Re: Error upon installation of Cute Live Support

    Ken,
     
    This is the support site -
     
    We used to have a link icon show up on our main website : http://www.qmiusa.com (at the bottom, on the left side, next to "I'm a retailer" )
    The only issue we are having now is that this link icon disappeared.
    If you go to the tab on the top "Contact Us", the link over there works fine.
     
    The 2 clients having problems are working fine now somehow.
     
    Your help is greatly appreciated.
     
     
    Cindy
     
  •  02-29-2012, 10:51 AM 73262 in reply to 73247

    Re: Error upon installation of Cute Live Support

    Hi cliu,
     
    Please refer to http://www.cutesoft.net/live-support/Developer-Guide/scr/Adding-chat-button-tag.htm, check the deploy code
    <script src="http://www.cutesoft.net/CuteSoft_Client/CuteChat/Support-Image-Button.js.aspx"></script>
    <script src="http://www.cutesoft.net/CuteSoft_Client/CuteChat/Support-Visitor-monitor.js.aspx"></script>
     
    If you page http://www.qmiusa.com/Home.aspx, you are using the code below.
     
    CuteLiveSupport has not a page name  "Support-Image-Button-QMIHome.js.aspx ", that is why the button does not show up. I thought this is   your old chat button page created by your developer?
     
    <script src='http://support.roll-a-way.com/CuteSoft_Client/CuteChat/Support-Image-Button-QMIHome.js.aspx'>
     
    Regards,
     
    Ken 
     
  •  03-01-2012, 9:08 AM 73275 in reply to 73262

    Re: Error upon installation of Cute Live Support

    Ken,
     
    I sent an email to you yesterday with an attachment and further explaination. Please help. Thanks,
     
    Regards,
     
    Cindy Liu
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.