Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

HTTPS - How to get rid of warning/message caused by Cute Editor

Last post 04-06-2012, 8:26 AM by timw@acponline.org. 35 replies.
Page 2 of 2 (36 items)   < Previous 1 2
Sort Posts: Previous Next
  •  06-01-2010, 3:08 PM 61491 in reply to 61490

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    OlegS,
     
    Can you download the latest build then try again?

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  06-02-2010, 10:09 AM 61510 in reply to 61491

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Adam,
    I would like to try the update as well to see if it takes care of this issue.  However, before I can try this, I need to perform a file compare in order to preserve my customizations.  I seem to have misplaced my original download from 1/28/2010.  Do you have the older ZIP files posted somewhere?  Thank you so much.
     -Tim
     
    P.S. If you see this first, you can disregard my email.
  •  06-02-2010, 10:56 AM 61511 in reply to 61510

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Unfortunately, I can't test this because our test, qa, and uat environments are not set up with https.  I will wait for confirmation from someone on this thread and then push it to prod.
  •  06-02-2010, 3:16 PM 61515 in reply to 61511

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Bad news.  The latest version (Build 2010-05-26) didn't work for me; it still is trying to build the absolute path (and subsequently failing).  For my staging environment, the function returns this...
     
    http://acpportalstage.acponline.org/acpchapterportal/cutesoft_client/cuteeditor/Load.ashx?type=style&file=SyntaxHighlighter.css 
     
    ...when it should be returning a relative path like everything else.  Hence, the HTTPS mixed content warning.
     
    *sadface* 
  •  06-02-2010, 3:42 PM 61516 in reply to 61515

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Tim, this is the proper functionality (as it was before).  In order to do a proper test you would have to test it with ssl enabled and see once your site is running https whether that function call changes to https://someurl/SyntaxHighlighter.css instead of http://someurl/SyntaxHighlighter.css
     
    Thanks,
    Oleg
  •  06-02-2010, 3:57 PM 61517 in reply to 61516

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    O,
    Yes, we have an SSL certificate installed in this staging environment.
     
    That is exactly the point.  I am accessing the page via SSL and it *is* https.  Everything else on the page is referenced correctly - either via https/ssl or a relative path.  This is the only place where it seems to be ignorant to the protocol.
     
    Additionally, if I wasn't accessing the page via SSL, the mixed content warning would not appear at all.
    -T 
     
     
  •  06-08-2010, 9:26 AM 61629 in reply to 61515

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Adam,
    Any update to my 6/2/2010 3:16 PM post?  Thanks!
    -Tim
  •  06-14-2010, 8:21 AM 61726 in reply to 61629

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Adam,
    Any update to my 6/2/2010 3:16 PM post?  Thanks!
    -Tim
  •  06-14-2010, 10:11 PM 61741 in reply to 61726

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Hi timw@acponline.org,
     
    Try this way
     
    1. Clean all content of css file "CuteSoft_Client\CuteEditor\Style\SyntaxHighlighter.css" and try again.
     
    If it works, mean that the content cause this issue. you can remove the content one by one  to get the line wihic cause this issue.
     
    2. If not, please create a page only contains CuteEditor and send the test page url to me. I will test it and get back to you as soon as possible.
     
     
    Regards,
     
    ken
     
  •  06-15-2010, 8:55 AM 61750 in reply to 61741

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Ken,
    I have already removed line 26 from my current production environment's cutesoft_client/cuteeditor/template.aspx ...
     

    21 <html>
    22     <head>
    23         <title>Untitled</title>
    24         <meta name="GENERATOR" content="CuteEditor">
    25         <base target="_blank"  href="<%=Server.HtmlEncode(referrer)%>" />
    26         <link type="text/css" rel="stylesheet" href='<%=CuteEditor.EditorUtility.ProcessWebPath(Context,Page,"Load.ashx?type=style&file=SyntaxHighlighter.css")%>' />
    27     </head>
    28     <body>
    29     </body>
    30 </html>

     
    Removing this line does fix the secure/insecure mixed content warning problem, but it creates another problem...  When the user tries to apply formatting to a highlighted section of content, the formatting is applied to the entire content block.
     
    My assumption is that if you fix the CuteEditor.EditorUtility.ProcessWebPath() method to return a relative path rather than a full static URL, then the mixed content warning should go away.
    -Tim
  •  06-15-2010, 10:11 PM 61766 in reply to 61750

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    timw@acponline.org:
    Ken,
    I have already removed line 26 from my current production environment's cutesoft_client/cuteeditor/template.aspx ...
     

    21 <html>
    22     <head>
    23         <title>Untitled</title>
    24         <meta name="GENERATOR" content="CuteEditor">
    25         <base target="_blank"  href="<%=Server.HtmlEncode(referrer)%>" />
    26         <link type="text/css" rel="stylesheet" href='<%=CuteEditor.EditorUtility.ProcessWebPath(Context,Page,"Load.ashx?type=style&file=SyntaxHighlighter.css")%>' />
    27     </head>
    28     <body>
    29     </body>
    30 </html>

     
    Removing this line does fix the secure/insecure mixed content warning problem, but it creates another problem...  When the user tries to apply formatting to a highlighted section of content, the formatting is applied to the entire content block.
     
    My assumption is that if you fix the CuteEditor.EditorUtility.ProcessWebPath() method to return a relative path rather than a full static URL, then the mixed content warning should go away.
    -Tim
     
    Hi timw@acponline.org ,
     

    Try change line

    <link type="text/css" rel="stylesheet" href='<%=CuteEditor.EditorUtility.ProcessWebPath(Context,Page,"Load.ashx?type=style&file=SyntaxHighlighter.css")%>' />

    To

     <link type="text/css" rel=stylesheet  href="https://localhost/editor/CuteSoft_Client/CuteEditor/Load.ashx?type=style&file=SyntaxHighlighter.css" />

    https://localhost/editor/” is the site path in my case, please change to your site url.

    Regards,

    Ken

  •  06-17-2010, 10:25 AM 61849 in reply to 61766

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Ken,
     Thank you for the reply.  I have just tried this, but I am unclear whether or not it worked.  I replaced the line as you suggested, and the warning does not appear.  However, when I view the resulting source there is no reference at all to the syntaxhighlighter.css.  It looks as if the entire <link ... /> reference is not even there...  Yes, I have cleared my cache/browsing history/Ctrl+F5 with same result.
    Is this an expected behavior?  How can I verify that the CSS file is being properly included/referenced?
     -Tim 
  •  06-17-2010, 9:20 PM 61855 in reply to 61849

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    timw@acponline.org:
    Ken,
     Thank you for the reply.  I have just tried this, but I am unclear whether or not it worked.  I replaced the line as you suggested, and the warning does not appear.  However, when I view the resulting source there is no reference at all to the syntaxhighlighter.css.  It looks as if the entire <link ... /> reference is not even there...  Yes, I have cleared my cache/browsing history/Ctrl+F5 with same result.
    Is this an expected behavior?  How can I verify that the CSS file is being properly included/referenced?
     -Tim 
     
    Hi timw@acponline.org,
     
    You can try the "Syntax Highlighter Code" function to inster some code.
     
    If the stylesheet is applied, the cdoe will like beow
     
     
    else will like
     
     
    Regards,
     
    ken
  •  03-28-2012, 4:15 PM 73578 in reply to 61855

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Ken, et al,
    I realize that this is an old issue, but it still has not been fixed. In my last post, I stated that IE's lovely mixed content warning had stop appearing, but I must have been on drugs that day, because for the past two years, my users have continued to experience that problem.
     
    So... I have taken to experimenting with the reference to the file "cutesoft_client/cuteeditor/Load.ashx?type=style&file=SyntaxHighlighter.css" an watching the results via Fiddler (what a GREAT tool). No matter what I try, when loading the CuteEditor via SSL, the browser still requests that one file via http (over port 80).
    This is not cool dude.
    Since I only use the CE for html & text content editing, can I turn the "syntax highlighting" completely off such that the browser will never request this css file?  If not, when will this be fixed???
     
    Cheers!
    -Tim 
  •  03-29-2012, 10:14 AM 73581 in reply to 73578

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Hi timw@acponline.org,
     
    Please try the way below
     
    1. Open file "\CuteSoft_Client\CuteEditor\Template.aspx"
     
    2. Find section below and delete it
     
    <link type="text/css" rel="stylesheet" href='<%=CuteEditor.EditorUtility.ProcessWebPath(Context,Page,"Load.ashx?type=style&file=SyntaxHighlighter.css")%>' />

     
    Regards,
     
    Ken 
  •  04-06-2012, 8:26 AM 73650 in reply to 73581

    Re: HTTPS - How to get rid of warning/message caused by Cute Editor

    Ken,
    Wow - I owe you a huge apology. The last time I tested this, your solution of removing the offending line did not work (...wait for it...). However, upon further investigation I discovered that I had made yet another rookie mistake. It appears the Template.aspx file had been cached in the browser and I failed (epicly) to fully clear my cache.
     
    Long story short, removing the line fixes the problem. I humbly apologize for the abrasive tone of my previous posts.
     
    Nevertheless, for those lurkers out there who have this problem and would like to retain the code highlighting  feature, removing this reference is not an option. I politely suggest fixing this for them.
     
    ok I'm done.  Thanks for the help!!
    -Tim 
Page 2 of 2 (36 items)   < Previous 1 2
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.