Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Upload Module is not installed into the Web.config

Last post 06-23-2009, 12:45 PM by dmak. 12 replies.
Sort Posts: Previous Next
  •  06-23-2009, 11:23 AM 53409

    Upload Module is not installed into the Web.config

    I am using the multiple-files-upload.aspx method to upload files on my development box. I have bought the Ajaxuploader and installed the .dll and .lic file in the bin folder of the app.  I have the following references to the uploader in my web.config. 
     
    AppSettings
        <add key="CuteWebUI.AjaxUploader.GlobalMaxSizeKB" value="100000"/>
        <add key="CuteWebUI.AjaxUploader.TempDirectory" value="~/UploaderTemp"/>
     
    <system.web>
    <pages>
          <controls>
            <add namespace="CuteWebUI" assembly="CuteWebUI.AjaxUploader" tagPrefix="CuteWebUI"/>
       </controls>
        </pages>
     
     <httpModules>
    <add name="CuteWebUI.UploadModule" type="CuteWebUI.UploadModule,CuteWebUI.AjaxUploader"/>
    </httpModules>
     </system.web>
     
    The IIS version is 5.1.2600.0 (By looking at Computer Management -> Help -> About Computer Management) My dev box is a XP box and is not a Integrated environment.
     
    When I click on UPload Multiple files button, I get the "Upload Module is not installed into the Web.config!" error.  This happens only in C:\inetpub\wwwroot\app2.
     
    There is another app1 C:\inetpub\wwwroot\app1. The uploader works perfectly in app1. No issues in app1. I have compared the web.config in both the apps and I do not find any difference. I am using the same dll and lic file in both the apps.
     
    Appreciate your help.
     
    Thanks,
     
     
     
     
     
     
  •  06-23-2009, 11:27 AM 53410 in reply to 53409

    Re: Upload Module is not installed into the Web.config

    Hi,
     
    I guess your app2 is not an IIS application directory.
     
    Regards,
    Terry
     
  •  06-23-2009, 11:36 AM 53413 in reply to 53410

    Re: Upload Module is not installed into the Web.config

    No. It is a directory. I can access the other .aspx pages inside the app2 via a URL and those pages are functional.
     
    Thanks,
  •  06-23-2009, 11:55 AM 53415 in reply to 53413

    Re: Upload Module is not installed into the Web.config

    Hi,
     
    So can you open this file ?
     
     
    Regards,
    Terry
  •  06-23-2009, 11:58 AM 53417 in reply to 53415

    Re: Upload Module is not installed into the Web.config

    Yes, I see a green uploading image.
     
    Thanks.
  •  06-23-2009, 12:00 PM 53418 in reply to 53417

    Re: Upload Module is not installed into the Web.config

    That means the upload module works..
     
    If you open a page , please check the html source.
     
    Do you find the
     
    UploadModuleNotInstall="1"
     
    in the html source ?
     
    Regards,
    Terry
     
  •  06-23-2009, 12:02 PM 53419 in reply to 53418

    Re: Upload Module is not installed into the Web.config

    Yes.
  •  06-23-2009, 12:12 PM 53420 in reply to 53419

    Re: Upload Module is not installed into the Web.config

    In the same page , can you test this code ?
     
    <%=Context.Items[typeof(CuteWebUI.UploadModule)]%>
     
    uploader use it to determine whether the upload module is installed.
     
    Regards,
    Terry
  •  06-23-2009, 12:28 PM 53421 in reply to 53420

    Re: Upload Module is not installed into the Web.config

    I put this code Trace.Write("UPload Test" + Context.Items[typeof(CuteWebUI.UploadModule)].ToString());in the UploadMultipleFiles.aspx.cs file and I get Object Reference Not set to an instance of an object.
     
    Thanks.
     
  •  06-23-2009, 12:33 PM 53422 in reply to 53421

    Re: Upload Module is not installed into the Web.config

    Hi,
     
    That means , Context.Items[typeof(CuteWebUI.UploadModule)] is not setted by an unknown reason.
     
    Do your application use some special http modules or url rewrite module ?
     
    Regards,
    Terry
  •  06-23-2009, 12:34 PM 53423 in reply to 53422

    Re: Upload Module is not installed into the Web.config

    Currently you can get rid of this issue by this way:
     
    override protected void OnLoad(EventArgs args)
    {
        base.OnLoad(args);
        Context.Items[typeof(CuteWebUI.UploadModule)]=true;
    }
     
    Regards,
    Terry
     
  •  06-23-2009, 12:43 PM 53425 in reply to 53422

    Re: Upload Module is not installed into the Web.config

    Yes, I use CustomAuth httpmodule and it is set before the uploadmodule in httpmodules.
  •  06-23-2009, 12:45 PM 53427 in reply to 53423

    Re: Upload Module is not installed into the Web.config

    Thank you. This fixes it. I do see the upload window now. But however if I try to upload a file, I get Sys is undefined. I remove the CustomAuthmodule and I am able to upload the file without errors.
     
    There is a clash between CustomAuthmodule and CuteWeUploadModule. Let me look into the CustomAuthmodule.
     
    Thanks again.
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.