Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

DotNet Gallery only partially works under Firefox

Last post 07-20-2006, 4:49 PM by mbearden. 11 replies.
Sort Posts: Previous Next
  •  04-24-2006, 1:38 AM 18440

    DotNet Gallery only partially works under Firefox

    Are there any special conditional configuration steps I need to do for the gallery to work with Firefox?  Only things working are the first page thumbnails, the edit image (until you try to save), the upload image (although I can't tell where it goes).  Site works fine when viewed by Internet Explorer, unfortunately not all my clients use IE.

    James

  •  05-22-2006, 8:19 PM 19392 in reply to 18440

    Re: DotNet Gallery only partially works under Firefox

    I just noticed that DNG 1.2 with ASP.NET 2 doesn't work under Firefox like you mention, but DNG 1.1 with ASP.NET 1.1 does.
  •  05-22-2006, 10:10 PM 19399 in reply to 18440

    Re: DotNet Gallery only partially works under Firefox

    It looks like the problem is in the proceed javascript.  Under DNG 1.2 with ASP.NET 2 and Firefox it renders the javascript to look for GalleryControlName:currentpage, but the control is really getting named GalleryControlName$currentpage.
  •  06-23-2006, 6:13 PM 20443 in reply to 19399

    Re: DotNet Gallery only partially works under Firefox

    any news on this? I can't use without working on firefox. it's a deal-breaker.
  •  06-23-2006, 6:23 PM 20444 in reply to 20443

    Re: DotNet Gallery only partially works under Firefox

    I submitted a support request and any responses by me to CuteSoft get bounced back because thier support person mailbox is full.  I've been waiting a while for a fix.
  •  06-29-2006, 9:26 AM 20584 in reply to 20444

    Re: DotNet Gallery only partially works under Firefox

    I had the same problem. It seems to be an issue with Gallery 1.2 and the .NET framework 2.0. I swapped the web application back to use .NET Framework 1.1, and it is now working fine, also with Firefox.

    The problem is that the name generated for the input fields are for example "gallery1$currentpage", but the JavaScript is looking for an element with name "gallery1:currentpage". Interesting that the script works in IE, it obviously assumes that the name "gallery1$currentpage" and "gallery1:currentpage" is the same. With .NET framework 1.1 the name is generated with the colon, not with the dollar sign.

    Hope this helps

  •  07-15-2006, 3:05 PM 21003 in reply to 20584

    Re: DotNet Gallery only partially works under Firefox

    Any news on this? Or is there another work around that doesn't involve rolling back to the 1.1 Framework?

    Thank you,

    Michael

  •  07-19-2006, 3:36 AM 21049 in reply to 18440

    Re: DotNet Gallery only partially works under Firefox

    Due to a bug/feature of Javascript, the last function in always wins.  This means that you can have multiple function signatures and the last one defined will be the one that the browser uses.

    DIY solution for broken proceed(szHow,n)  function:
    (Put this code somewhere after the control pastes its own script code - I put it toward the </body> tag to be safe)

    <script language="javascript">
         function proceed(szHow,n)
         {
             var theform;
             if (window.navigator.appName.toLowerCase().indexOf("netscape") > -1) //If Gecko agent
             {
                 theform = document.forms["form1"];
                 var temp,temp1;
                 temp = GetElementByName2(theform,"gallery$currentpage"); //Changed : to $
                 temp1 = GetElementByName2(theform,"gallery$current_slideshow"); //Changed : to $
                 temp.value=n;
                 temp1.value=szHow;
             }
             else //If IE
             {
                 theform = document.form1;
                 theform.gallery_currentpage.value=n;
               
                 theform.gallery_current_slideshow.value=szHow;
             }
             if(szHow=="Slideshow")
                 window.setTimeout("__doPostBack('gallery','')", 3000);
             else
                __doPostBack('gallery','')
         }
    </script>

    Now this solution checks out in Firefox, Camino, Safari, and IE.  I haven't actually tried it on Netscape Navigator, but if it gives you problems, you can always include a separate test:

    if (window.navigator.appName.toLowerCase().indexOf("netscape") > -1)
    {
            theform = document.forms["form1"];
            var temp,temp1;
            temp = GetElementByName2(theform,"gallery:currentpage");
            temp1 = GetElementByName2(theform,"gallery:current_slideshow");
            temp.value=n;
            temp1.value=szHow;
    }
    else if (window.navigator.appName.toLowerCase().indexOf("firefox") > -1)
    {
            theform = document.forms["form1"];
            var temp,temp1;
            temp = GetElementByName2(theform,"gallery$currentpage"); //Changed : to $
            temp1 = GetElementByName2(theform,"gallery$current_slideshow"); //Changed : to $
            temp.value=n;
            temp1.value=szHow;
    }

    I hope this helps, although my favorite solution is Cutesoft fixing their product on their own.

    Matt

  •  07-19-2006, 11:57 PM 21113 in reply to 21049

    Re: DotNet Gallery only partially works under Firefox

    Guys,
     
    We fixed this issue in the new build of the version 1.2. Sorry for the late resonse.
     
    Matt, Thanks for the hack.  We provide a bettter solution in the new build. Please download it from:
     
     



    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  07-20-2006, 12:10 AM 21117 in reply to 21113

    Re: DotNet Gallery only partially works under Firefox

    Again every post in this thread mentions that 1.2 doesn't work.  As in 1.2 does not work.
  •  07-20-2006, 12:20 AM 21119 in reply to 21117

    Re: DotNet Gallery only partially works under Firefox

  •  07-20-2006, 4:49 PM 21147 in reply to 21119

    Re: DotNet Gallery only partially works under Firefox

    The 1.2.1 update seems to be working in Opera, Firefox and IE.  Thank you,
     
    Matt - Thank you very much for the work around.  Your effort is appreciated!
     
    Michael
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.