Live Support, Chat, Upload Control and Rich Text Editor
Welcome to Support forums Sign in | Join | Help |Client Center
in Search

Upgrading to 5.1 version

Last post 03-29-2006, 10:06 AM by darias. 21 replies.
Page 1 of 2 (22 items)   1 2 Next >
Sort Posts: Previous Next
  •  03-16-2006, 1:57 PM 17282

    Upgrading to 5.1 version

    I installed the files and the license as per instructions given and the error _CState is popping up. The screen below is from the fullscreen.asp sample. I had to change the MSXML2.Document.4.0 objects to MSXML2.Document because I have no that object in my server.
     
    I deleted all the files, restart my IIS, clean my cache and installed again all the files and the error is still coming.
     
    Any idea?
     
     
     
  •  03-17-2006, 4:01 AM 17294 in reply to 17285

    Re: Let's try on your localPC first

    Hi Karen,
     
    Indeed, in my local PC works and I haven't had to change the references to the object MSXML2.Document.4.0.
     
    What's next?
     
    David
  •  03-17-2006, 3:41 PM 17332 in reply to 17282

    Re: Upgrading to 5.1 version

     normally when I see the _Cstate, the editor.FilesPath is pointing to the wrong place.
     
    RC
  •  03-20-2006, 12:48 PM 17373 in reply to 17332

    Re: Upgrading to 5.1 version

    Hi RC, I have the same configuration I had with the version 5. However, the error is also popping up with the demos.
     
    David
     
  •  03-20-2006, 1:26 PM 17379 in reply to 17373

    Re: Upgrading to 5.1 version

    David,
     
    What file is causing the error? Is it when yo invoke the editor.draw()?

     
    RC
  •  03-20-2006, 1:47 PM 17382 in reply to 17379

    Re: Upgrading to 5.1 version

    Indeed.
  •  03-20-2006, 3:14 PM 17394 in reply to 17382

    Re: Upgrading to 5.1 version

    darias,

    Can you create a simple asp page which can demonstrate the problems and post the code here?
     
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  03-20-2006, 3:19 PM 17396 in reply to 17394

    Re: Upgrading to 5.1 version

    Adam,
     
    I had the problem with my code the one is working perfectly with version 5 and then I installed all in a new directory and I have the problem with the samples (e.g. fullscreen.asp) so I haven't changed any line in the code included in the zip I downloaded.
     
    David
     
  •  03-20-2006, 3:26 PM 17403 in reply to 17396

    Re: Upgrading to 5.1 version

    David,
     
    Please post your code. Maybe the changes/improvements in the version 5.1 have some conflicts with your existing code.
     
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  03-20-2006, 3:33 PM 17405 in reply to 17403

    Re: Upgrading to 5.1 version

    Hi Adam,
     
    I'm not in my work now, so I'll send you the code tomorrow. However, as I said, the code should be the same in the version 5, isn't it? So, why is not working now?. I'll send you the code of your own samples and if you help me to make your own code working in my IIS server, I will know if something is wrong in my code.
     
    The only thing I could see but probably you must know is that _CState reference seems to come from a problem when creating the object. It looks like the object is not properly created and then _CState is trying to access it.
     
    David
  •  03-22-2006, 12:49 PM 17460 in reply to 17405

    Re: Upgrading to 5.1 version

    Hi Adam, find below the code in the fullscreen.asp:
     
    <!-- #include file = "CuteEditor_Files/include_CuteEditor.asp" -->
    <html> 
        <head>
      <link rel="stylesheet" href="asp.css"  type="text/css" />
     </head>
        <body>
      
      <form name="theForm" action="Get_HtmlContent.asp" method="post" ID="Form1">
      <h1>Full screen mode</h1>
      <hr>
      <div class="infoBox">
        Full screen mode button (F12 shortcut)  allows you to stretch the Cute Editor control to the width and height of your browser window. <BR>
      </div>
      <br />
      <%
       dim content
       content = "Type here"   
         
       Dim editor
       Set editor = New CuteEditor
       editor.ID = "Editor1"
       editor.Text = content
       editor.FilesPath = "CuteEditor_Files"
       editor.FullPageOnload = true
       editor.EditorBodyStyle = "table { font:normal 12px arial; }"
       editor.EditorWysiwygModeCss = "asp.css"
       editor.Draw()
                
       ' Request.Form(ID) access from other page
      %>
          
      </form>
     </body>
    </html>
     
  •  03-23-2006, 10:09 PM 17532 in reply to 17460

    Re: Upgrading to 5.1 version

    David,
     
    I've tested your code. It works fine here.
     
    Can you explain your sitr structure?
     
    There are many possible answers for this kind of error. I need to know how you configure your site first.
     
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  03-24-2006, 7:27 AM 17551 in reply to 17282

    Re: Upgrading to 5.1 version

    You need to download and install MXSML 4:
     
    Download the file, extract the files inside using winzip, put in the \system32 directory on your server, run a command prompt and type "regsvr32 \windows\system32\msxml4.dll".
     
  •  03-24-2006, 8:51 AM 17555 in reply to 17532

    Re: Upgrading to 5.1 version

    Adam,
     
    I told you that the server is the same server where the version 5.0 is running without any problem. I just did the same I did when my boss asked me to install the version 5.0 for the first time, copy the files.... nothing else!
     
    If any other different version of MSXMLDOM must be installed you should specify when releasing new versions which are the requirements cuteeditor version 5.1 needs and I'll have a look and I will ask to install in those libraries or whatever which our server wouldn't has installed.
     
    David
  •  03-24-2006, 1:41 PM 17565 in reply to 17555

    Re: Upgrading to 5.1 version

    David,
     
    Please download the version 5.1 again.
     
    In the current build, I just replaced
     
    MSXML2.DomDocument.4.0
     
    With
     
    Microsoft.XMLDOM
     
    Hope it helps.
     
    Keep me posted
     
     
     

    asp.net Chat http://cutesoft.net/ASP.NET+Chat/default.aspx
    Web Messenger: http://cutesoft.net/Web-Messenger/default.aspx
    asp.net wysiwyg editor: http://cutesoft.net/ASP.NET+WYSIWYG+Editor/default.aspx
    asp wysiwyg html editor: http://cutesoft.net/ASP
    asp.net Image Gallery: http://cutesoft.net/ASP.NET+Image+Gallery/default.aspx
    Live Support: http://cutesoft.net/live-support/default.aspx

  •  03-27-2006, 7:35 AM 17597 in reply to 17565

    Re: Upgrading to 5.1 version

    Hi Adam,
     
    It seems to be working properly, I haven't checked deeply but at least all of those nasty errors I had last week are not coming  up.
     
    The problem now is that my license doesn't seem to be the appropriate one for that new version I have downloaded:
     
     
    And again, the dropdown backdropcolor and the foredropcolor don't work.
     
    Maybe I'm doing something wrong, but as I said there is no any sample in your website to see if those dropdown list really work.
     
    David
  •  03-27-2006, 1:59 PM 17615 in reply to 17597

    Re: Upgrading to 5.1 version

    When you recieved and email from cutesoft about downloading the editor, there was a license file attached. The download contains a generic license, you must replace that license sith the one that was sent to you.
     
    RC
  •  03-27-2006, 5:55 PM 17636 in reply to 17615

    Re: Upgrading to 5.1 version

    Hi Robert,
     
    I copied that file in the license folder as usual in the last installations I have been doing lately. The only error I haven't had until now and the only one I wasn't expecting is a problem with the license
     
    Thanks anyway,
     
    David
  •  03-29-2006, 2:35 AM 17682 in reply to 17636

    Re: Upgrading to 5.1 version

    I think they are having problems with new ASP license development, the 5.1 version is not working right to me too: I hope they are fixing it, since they did even not answered my email with developing suggestions.
     
    One more thing is: what happened to the "context menu" ? It seems is not working on the ASP Version.
     
    Last suggestion goes to developers: as a general rule, you should NOT REISSUE an update to a software under the same version number !!!!!!!!!!!!!!!!!!!! This way different persons having same versions are having different products ! Versioning does -NOT- cost you: if you find some bugs on the 5.1 you should issue a 5.2, and so on ... I think cutesoft is a really tiny and starting "software company" : you're on the right way, but you should seriously consider our suggestions to keep your work better and better.
     
    Awayting your news !!!!!
     
Page 1 of 2 (22 items)   1 2 Next >
View as RSS news feed in XML
Powered by ASP.Net
Copyright 2003 - 2017 CuteSoft Components Inc.. All rights reserved.